Error after upgrading freepbx 15 to 16

Hi mates!

I have just upgraded my FreePBX 15 to 16 using the GUI Tool.

Everything is working but in the System Update page is shown an error:

Undefined variable: pkglist
File:/var/www/html/admin/libraries/Builtin/SystemUpdates.php:435

if you have SSH check your modules list, maybe not installed some modules ?

fwconsole ma list
and
yum update

//not installed package present so might not be the real failureā€¦ continue with processingā€¦

No repos specified, using: [standard] from last GUI settings

Ā±--------------------Ā±-----------Ā±--------------Ā±------------+
| Module | Version | Status | License |
Ā±--------------------Ā±-----------Ā±--------------Ā±------------+
| accountcodepreserve | 16.0.0.1 | Habilitado | GPLv2 |
| adv_recovery | 16.0.28 | Habilitado | Commercial |
| amd | 16.0.1 | Habilitado | GPLv3+ |
| announcement | 16.0.4 | Habilitado | GPLv3+ |
| api | 16.0.4.8 | Habilitado | AGPLv3+ |
| areminder | 16.0.9 | Habilitado | Commercial |
| arimanager | 16.0.4 | Habilitado | GPLv3+ |
| asterisk-cli | 16.0.2 | Habilitado | GPLv3+ |
| asteriskinfo | 16.0.5 | Habilitado | GPLv3+ |
| backup | 16.0.50.5 | Habilitado | GPLv3+ |
| blacklist | 16.0.5 | Habilitado | GPLv3+ |
| broadcast | 16.0.8 | Habilitado | Commercial |
| builtin | | Habilitado | |
| bulkhandler | 16.0.3 | Habilitado | GPLv3+ |
| calendar | 16.0.6 | Habilitado | GPLv3+ |
| callaccounting | 16.0.3 | Habilitado | Commercial+ |
| callback | 16.0.2 | Habilitado | GPLv3+ |
| callerid | 16.0.4 | Habilitado | Commercial |
| callforward | 16.0.5 | Habilitado | AGPLv3+ |
| calllimit | 16.0.4 | Habilitado | Commercial |
| callrecording | 16.0.7 | Habilitado | AGPLv3+ |
| callwaiting | 16.0.4 | Habilitado | GPLv3+ |
| cdr | 16.0.9 | Habilitado | GPLv3+ |
| cel | 16.0.5 | Habilitado | GPLv3+ |
| certman | 16.0.19 | Habilitado | AGPLv3+ |
| cidlookup | 16.0.5 | Habilitado | GPLv3+ |
| conferences | 16.0.6 | Habilitado | GPLv3+ |
| conferencespro | 16.0.6 | Habilitado | Commercial |
| configedit | 16.0.2 | Habilitado | AGPLv3+ |
| contactmanager | 16.0.11 | Habilitado | GPLv3+ |
| core | 16.0.56.16 | Habilitado | GPLv3+ |
| cos | 16.0.3 | Habilitado | Commercial |
| customappsreg | 16.0.3 | Habilitado | GPLv3+ |
| cxpanel | 16.0.2 | Habilitado | GPLv3 |
| dahdiconfig | 16.0.4 | Habilitado | GPLv3+ |
| dashboard | 16.0.8 | Habilitado | AGPLv3+ |
| daynight | 16.0.1 | Habilitado | GPLv3+ |
| dictate | 16.0.1 | Habilitado | GPLv3+ |
| directory | 16.0.1 | Habilitado | GPLv3+ |
| disa | 16.0.1 | Habilitado | AGPLv3+ |
| donotdisturb | 16.0.3 | Habilitado | GPLv3+ |
| dynroute | 15.0.2 | Habilitado | GPLv3+ |
| endpoint | 16.0.59.23 | Habilitado | Commercial |
| extensionroutes | 16.0.6 | Habilitado | Commercial |
| extensionsettings | 16.0.1 | Habilitado | GPLv3+ |
| fax | 16.0.3 | Habilitado | GPLv3+ |
| faxpro | 16.0.5 | Habilitado | Commercial |
| featurecodeadmin | 16.0.1 | Habilitado | GPLv3+ |
| filestore | 16.0.10.6 | Habilitado | AGPLv3 |
| findmefollow | 16.0.7 | Habilitado | GPLv3+ |
| firewall | 16.0.42.10 | Habilitado | AGPLv3+ |
| framework | 16.0.10.34 | Habilitado | GPLv2+ |
| fw_langpacks | 16.0.1 | Habilitado | GPLv3+ |
| hotelwakeup | 16.0.1 | Habilitado | GPLv2 |
| iaxsettings | 16.0.1 | Habilitado | AGPLv3 |
| infoservices | 16.0.2 | Habilitado | GPLv2+ |
| iotserver | 16.0.0.4 | Habilitado | Commercial |
| irc | 16.0.1 | Habilitado | GPLv3+ |
| ivr | 16.0.3 | Habilitado | GPLv3+ |
| languages | 16.0.1 | Habilitado | GPLv3+ |
| logfiles | 16.0.2 | Habilitado | GPLv3+ |
| manager | 16.0.9 | Habilitado | GPLv2+ |
| miscapps | 16.0.1 | Habilitado | GPLv3+ |
| miscdests | 16.0.1 | Habilitado | GPLv3+ |
| music | 16.0.1 | Habilitado | GPLv3+ |
| oracle_connector | 16.0.13 | Habilitado | Commercial |
| outroutemsg | 16.0.1 | Habilitado | GPLv3+ |
| paging | 16.0.8 | Habilitado | GPLv3+ |
| pagingpro | 16.0.7 | Habilitado | Commercial |
| parking | 16.0.2 | Habilitado | GPLv3+ |
| parkpro | 16.0.2 | Habilitado | Commercial |
| pbdirectory | 2.11.0.6 | Habilitado | GPLv3+ |
| phonebook | 16.0.1 | Habilitado | GPLv3+ |
| phpinfo | 16.0.1 | Habilitado | GPLv2+ |
| pinsets | 16.0.6 | Habilitado | GPLv3+ |
| pinsetspro | 16.0.4 | Habilitado | Commercial |
| pm2 | 16.0.5 | Habilitado | AGPLv3+ |
| pms | 16.0.14 | Habilitado | Commercial |
| presencestate | 16.0.1 | Habilitado | GPLv3+ |
| printextensions | 16.0.1 | Habilitado | GPLv3+ |
| queueprio | 16.0.2 | Habilitado | GPLv3+ |
| queues | 16.0.13 | Habilitado | GPLv2+ |
| queuestats | 16.0.12 | Habilitado | Commercial |
| qxact_reports | 16.0.6 | Habilitado | Commercial |
| recording_report | 16.0.12 | Habilitado | Commercial |
| recordings | 16.0.5 | Habilitado | GPLv3+ |
| restapps | 16.0.18.21 | Habilitado | Commercial |
| ringgroups | 16.0.6 | Habilitado | GPLv3+ |
| sangomaconnect | 16.0.18.10 | Habilitado | Commercial |
| sangomacrm | 16.0.10.6 | Habilitado | Commercial |
| sangomartapi | 16.0.2 | Deshabilitado | Commercial |
| setcid | 16.0.3 | Habilitado | GPLv3+ |
| sipsettings | 16.0.15 | Habilitado | AGPLv3+ |
| sipstation | 16.0.11 | Habilitado | Commercial |
| sms | 16.0.3 | Habilitado | Commercial |
| soundlang | 16.0.6 | Habilitado | GPLv3+ |
| speeddial | 2.11.0.4 | Habilitado | GPLv3+ |
| superfecta | 16.0.13 | Habilitado | GPLv2+ |
| sysadmin | 16.0.5.65 | Habilitado | Commercial |
| timeconditions | 16.0.8 | Habilitado | GPLv3+ |
| tts | 16.0.2 | Habilitado | GPLv3+ |
| ttsengines | 16.0.3 | Habilitado | AGPLv3 |
| ucp | 16.0.15 | Habilitado | AGPLv3+ |
| userman | 16.0.25.14 | Habilitado | AGPLv3+ |
| vega | 16.0.4 | Habilitado | Commercial+ |
| vmblast | 16.0.4 | Habilitado | GPLv3+ |
| vmnotify | 16.0.3 | Habilitado | Commercial |
| voicemail | 16.0.21 | Habilitado | GPLv3+ |
| voicemail_report | 16.0.3 | Habilitado | Commercial |
| voipinnovations | 16.0.12 | Habilitado | Commercial |
| vqplus | 16.0.6 | Habilitado | Commercial |
| weakpasswords | 16.0.1 | Habilitado | GPLv3+ |
| webcallback | 16.0.3 | Habilitado | Commercial |
| webrtc | 16.0.9 | Habilitado | GPLv3+ |
| xmpp | 16.0.5 | Habilitado | AGPLv3 |
| zulu | 16.0.10 | Habilitado | Commercial |
Ā±--------------------Ā±-----------Ā±--------------Ā±------------+

yum update
Loaded plugins: fastestmirror, versionlock
Repository sng-sng7php74 is listed more than once in the configuration
Loading mirror speeds from cached hostfile
No packages marked for update

The problem continuesā€¦

fwconsole chown
fwconsole r --verbose

Plz^^

fwconsole chown
Taking too long? Customize the chown command, See http://wiki.freepbx.org/display/FOP/FreePBX+Chown+Conf
Setting Permissionsā€¦
Setting base permissionsā€¦Hecho in 24 seconds
Setting specific permissionsā€¦
54758 [============================]
Finished setting permissions

fwconsole r --verbose
Reload Started
Reload Complete

After that it is shown a new update:

If i click on REFRESH PAGE the problem continues

Can i do the update?

Do it update. And try to add 2nd or 3rd Google DNS 8.8.8.8 & 8.8.4.4

I have changed the DNS but it nos possible to complete de update

Operating System Updates (In Progress)


Loaded plugins: fastestmirror, versionlock
Repository sng-sng7php74 is listed more than once in the configuration
Loading mirror speeds from cached hostfile

Operating System Updates (Complete)


Transaction Summary : No packages marked for update

The error is still shown:

Missing Repo, try to update it

yum -y update
yum clean all

yum -y update
Loaded plugins: fastestmirror, versionlock
Repository sng-sng7php74 is listed more than once in the configuration
Loading mirror speeds from cached hostfile
No packages marked for update

yum clean all
Loaded plugins: fastestmirror, versionlock
Repository sng-sng7php74 is listed more than once in the configuration
Cleaning repos: sng-base sng-epel sng-extras sng-pkgs sng-sng7php74 sng-updates
Cleaning up list of fastest mirrors
Other repos take up 115 M of disk space (use --verbose for details)

yum update

check again try to update

also what is your disk storage space ?

df -h

yum update
Loaded plugins: fastestmirror, versionlock
Repository sng-sng7php74 is listed more than once in the configuration
Determining fastest mirrors
sng-base | 3.6 kB 00:00:00
sng-epel | 2.9 kB 00:00:00
sng-extras | 2.9 kB 00:00:00
sng-pkgs | 3.4 kB 00:00:00
sng-sng7php74 | 3.4 kB 00:00:00
sng-updates | 2.9 kB 00:00:00
(1/7): sng-base/7-8.2003.5.el7.sangoma/x86_64/group_gz | 153 kB 00:00:00
(2/7): sng-sng7php74/7-8.2003.5.el7.sangoma/x86_64/primary_db | 91 kB 00:00:00
(3/7): sng-extras/7-8.2003.5.el7.sangoma/x86_64/primary_db | 206 kB 00:00:00
(4/7): sng-pkgs/7-8.2003.5.el7.sangoma/x86_64/primary_db | 1.0 MB 00:00:00
(5/7): sng-base/7-8.2003.5.el7.sangoma/x86_64/primary_db | 6.1 MB 00:00:01
(6/7): sng-updates/7-8.2003.5.el7.sangoma/x86_64/primary_db | 4.5 MB 00:00:01
(7/7): sng-epel/7-8.2003.5.el7.sangoma/x86_64/primary_db | 7.3 MB 00:00:02
No packages marked for update

df -h
Filesystem Size Used Avail Use% Mounted on
devtmpfs 1.9G 0 1.9G 0% /dev
tmpfs 1.9G 16K 1.9G 1% /dev/shm
tmpfs 1.9G 8.7M 1.9G 1% /run
tmpfs 1.9G 0 1.9G 0% /sys/fs/cgroup
/dev/mapper/SangomaVG-root 25G 7.3G 18G 30% /
/dev/xvda1 1.9G 61M 1.8G 4% /boot
tmpfs 378M 0 378M 0% /run/user/995
tmpfs 378M 0 378M 0% /run/user/0

Okay, Try again on CLI

fwconsole ma refreshsignatures
fwconsole ma upgradeall
fwconsole chown
fwconsole r --verbose

also check web page update for sng-sng7php74 is there or not?

fwconsole ma refreshsignatures
Everything GOOD

fwconsole ma upgradeall
No repos specified, using: [standard] from last GUI settings
Up to date.
Updating Hooksā€¦Hecho

fwconsole chown
Taking too long? Customize the chown command, See http://wiki.freepbx.org/display/FOP/FreePBX+Chown+Conf
Setting Permissionsā€¦
Setting base permissionsā€¦Hecho in 26 seconds
Setting specific permissionsā€¦
54752 [============================]
Finished setting permissions

fwconsole r --verbose
Reload Started
Reload Complete

The update was at the same point, sng-sng7php74 was there, i click on refresh page and check online and the problem continuesā€¦

No idea, Sorry,

fwconsole ma listonline --edge | grep framework

upgrade to edge

fwconsole ma downloadinstall --edge framework

maybe you can try to upgrade to --edge version your framrwork ?
and check your PBX license

fwconseol sa u

fwconsole ma listonline --edge | grep framework
| framework | 16.0.10.34 | Online upgrade available (16.0.10.40) | GPLv2+ |

fwconsole ma downloadinstall --edge framework <== what is edge? is it secure to do this update?

fwconseol sa u
-bash: fwconseol: command not found

Your system edge version shows 16.0.10.40
Edge means --> new version before QA,

I think you can update to edge its secure. also any time you can back to stabile version.
Try to update EDGE.

fwconsole ma downloadinstall --edge framework

sorry for typos, should be

fwconsole sa u
fwconsole sa info

fwconsole ma downloadinstall --edge framework
Edge repository temporarily enabled
No repos specified, using: [standard] from last GUI settings

Downloading module ā€˜frameworkā€™
Processing framework
Downloadingā€¦
16305550/16305550 [============================] 100%
Finished downloading
Extractingā€¦Done
Download completed in 10 seconds
Updating tables admin, ampusers, cronmanager, featurecodes, freepbx_log, freepbx_settings, globals, module_xml, modules, notifications, cron_jobsā€¦Hecho
Determined Asterisk version to be: 16.20.0
installing files to /var/www/htmlā€¦done
installing files to /var/lib/asterisk/binā€¦done
installing files to /var/lib/asterisk/agi-binā€¦done
Checking for upgradesā€¦
No further upgrades necessary
framework file install done, removing packages from module
file/directory: /var/www/html/admin/modules/framework/amp_conf removed successfully
file/directory: /var/www/html/admin/modules/framework/upgrades removed successfully
file/directory: /var/www/html/admin/modules/framework/start_asterisk removed successfully
file/directory: /var/www/html/admin/modules/framework/install removed successfully
file/directory: /var/www/html/admin/modules/framework/installlib removed successfully
Compressing Framework CSSā€¦Hecho
Setting Framework Versionā€¦Hecho
which: no amportal in (/usr/local/sbin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/root/bin)
Running SQL cleanupā€¦Hecho
Building Packaged Scriptsā€¦Hecho
Refreshing GPG Keysā€¦Hecho
Generating CSSā€¦Hecho
Module framework version 16.0.10.40 successfully installed
Updating Hooksā€¦Hecho
Chowning directoriesā€¦Done
Resetting temporarily repository state

fwconsole sa u
Updating license for 39247921
Done!
No changes from original Licence.

fwconsole sa info
Activation Status
Machine ID: 36:85:C8:XX:XX:XX
Lic File: Present
Deployment: 39247XXX

XXX is an edited text to not publish the real data

Still you have same problem ?