EPM update Aastra codec settings

Hello everyone,

So, I just bought my first couple g729 licenses (from digium). All installed on server great.

Now here is my issue, or at least I think. I assume that you want to use g729 from carrier to FreePBX to the Phone. So, I went to the device module and disallowed all and allowed g729, suddenly no audio. CLI gives an error of no usable path I think.

I logged into the phone (Aastra 6753i and Aastra 6739i) inside the sip menu there is a codec section in which g729 was not enabled - enabled it all is well.

But, I use EPM(commercial) to manage the phones, I did not see anywhere in EPM to set the codecs - I looked in the base file editor and did see some refs to codecs but they seemed model specific and none were for my models. I can login to each phone and update but when we do a firmware update wont it erase those settings. So, I was hoping to find a way for EPM to do the update, is it possibe?

Also, somewhat on topic - I was told by carrier that I had to disable all codecs other than g729 if I wanted to use it, otherwise FreePBX will always default to ulaw - is that correct?

Thanks again

Not quite, Asterisk will use the first codec on the list of allowed ones that is acceptable to all parties.

Order the list appropriately for extensions AND trunks, or it might not always choose your preferred one :wink:

OK, that makes perfect sense - thanks

Do you notice a big difference using g729?

If you have limited bandwidth, it is more than acceptable in quality, not quite g711 though.

Cable connection 1 meg up but normally only sees about half that and constantly uploading to the cloud - hoping this helps.

Are you familiar with my EPM question?

Sorry, I still use the Aastra xml based provisioning for Aastras.

I did find the answer to this in case anyone else is looking:
you need to edit the basefile of the config template that you need to change to codec order of:
change the line:
sip customized codec - value will read a string listing payloads
ex: payload=18;ptime=20;silsupp=on, payload=9;ptime=20;silsupp=on, payload=0;ptime=20;silsupp=on,payload=8;ptime=20;silsupp=on

change or add the payload for the codec you need:

rebuild the template - and push to phone and it will update the aastra phones to reflect the new codec settings.

Don’t forget g.729 requires a license from Digium.