EPM & Sangoma DECT (DB20)

I set up one I just got in the mail last week (db20 base).

For provisioning, it started by spamming my TFTP server with RRQ for /pvelinux.0. After I turned off Option 66 support, it started looking for /Config/[MAC].cfg. EPM is creating /[MAC].cfg, so I copied the configuration file to /Config/[MAC].cfg and it picked up the configuration immediately.

Unfortunately, despite having an extension set up for my base station with the correct IMEI, the only thing that shows up in my DB20 admin page is the extension configuration, it doesn’t get mapped to the phone via IMEI. I can manually click it and assign, and it persists through reboots.

Also, the base station pairing code I chose in the EPM didn’t provision either, and I had to change the default 0000 manually as well.

I will say that the audio sounds very nice (handsets support G722) and the range is better than I expected (I was expecting typical 1990’s cordless range/quality). I also really like that the nimh batteries are replaceable.

Update: I found that on another system, the EPM acts very differently when adding a db20 extension. On the other system, I select the phone brand, model, and then the entry form changes and adds an ‘extension’ area where I can map in my handset. On my problem system, I do this and nothing changes (mac address still available); I can only input the information after the extension is created by clicking on the ‘edit’ button (though it still doesn’t work to provision the extension properly).

I think this was caused by a ‘restore.’ I had so many problems trying to update my module after renewing, and support was ready to jump in and help but they responded after I had left for vacation. When I got back, the correct versions were available to download, but I had uninstalled EPM trying to get it to update properly and it deleted all my settings, so I did a… restore from backup (just pbx settings). This has apparently caused some versioning issues, as it seems backup & restore tends to do.

I’m thinking it’s a module that got updated and then it’s table was restored (like ‘core’ or ‘framework’), changing the settings to work with a previous version. Could someone point out the modules that EPM depends on so I can re-install them and get them to process things correctly? I suppose I could just go down the list and ‘fwconsole ma downloadinstall [modulename]’ but I wanted a more targeted approach.

I know I’m not supposed to use backup and restore. I don’t need to be admonished for it.

Did an fwconsole ma list, and created scripts to download and install all of my enabled modules. This did nothing to the epm. :frowning: Not sure what to try next; if I restore my system’s vm from last week before I made the changes, it will appear as new hardware and I’ll have a big headache with Zend resets and commercial licensing.

Which endpoint version do you have installed?

14.0.2.97; the same version installed on the working pbx. I should change the topic to “backup and restore screwed me, but I was warned”.

I tried to do a better restore and grab the older modules as well as restore the pbx settings. Did this, updated the modules, same behavior.

I’m hoping that with coming updates, the problem will be resolved. Otherwise, I just won’t be able to use provisioning for these phones at this location.

Try re-installing the module

fwconsole ma downloadinstall endpoint --force

Still exhibiting the same behavior. It’s also a little quirky with check boxes and displaying the ‘save’ drop down / button. Sometimes that save button/drop down is not present, and I need to check/uncheck boxes in order to get it to appear.

I tried using the --force option on 'framework as well. No change.

Perhaps this is browser cache issue?

You are a fantastic human being. Thank you for this solution, and helping me work through it! Perhaps it should have been more obvious to me…

1 Like

I’d also like to add that the configuration files created with the working EPM module are fantastic and worked with no messing around.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.