FreePBX | Register | Issues | Wiki | Portal | Support

EPM not able to push config to Sangoma phones


(Lolo) #1

Hello
Hello, This is the first time I set up freepbx and Endpoint manager , so I am not sure if I have set up everything correctly but I have set up the global setting in EPM, config the right model and relevant config. I can force phone to check config from freepbx web gui and the screen will show provision sucessful. but none of the config will register on the phone.
for example the phone gui password will not change nor the date or the picture.
I have tried TFTP & Http but none of it works like it should. I have also tried remove the EPM & reinstall it, still doesn’t work.
Also, although firmware managment has succesfuly installed in the firmware slot 1 but it doesn’t update to the phone.
Am I missing some steps? can someone please give me some pointers.
Thanks a lot

Current PBX Version: 14.0.5.25
Current System Version:12.7.5-1807-1.sng7
Sangoma Phone 405 & 505


(Itzik) #2

Did you rebuilt the template after making changes?


(Lolo) #3

Thank you for your reply , and yes I have rebuild config before push to the phones


(Itzik) #4

What happens if you reboot the phone, Does it pull the right config?


(Tom Ray) #5

Keep in mind, phones pull their configs, they are never pushed. So the EPM is not pushing files, the phone needs to request them.


(Lolo) #6

Thanks for everyone’s reply.
It turns out that, I have inputted port 83 instead of 84 for the DHCP options 66 values.
now that the problem has been solved, the new problem has showed up.
I can upload image photos in EPM but the phones won’t pull from the PBX.
I have SSH into the system, and found out that while photos have been uploaded to /tftpboot/images/originals but there are no uploaded photos in formatted folder.
the photos I have uploaded are below 256k jpg file.
can someone tell me what should I do to detect or fix this problem?


(system) closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.