EPM module not creating proper files for Cisco SPA1X2


(Steve Grant) #1

So after testing and looking at the base files for SPA112 in EPM I found the files generated by EPM for these devices in /tfptboot are being rejected by the ATAs (at least the several I have tried)

If replace the created file with the output of a configured device it does provision and accept the file.

The one thing I noticed in the xml files generated they are missing

<?xml version="1.0"?>

at the top of the file.

I tried adding this via basefile editor but was not able to add it to the top of file. Is there a way for my to mod the template to have <?xml version="1.0"?> show up at the top of file? I think this would fix the issue of rehected xml files.


(Jared Busch) #2

If you take the generated file and manually add the header does it work?

If so open a bug report on it.


(Steve Grant) #3

I just tried this and no… it still does not register sadly…

it must be a bad line in the file… I am trying to compare the out put of config.xml to the spa.xml file to see what could be wrong but its tough going.

I am surprised this has not come up before?
Regards