FreePBX | Register | Issues | Wiki | Portal | Support

EPM HTTP/HTTPS Provisioning Issues


(Kenny Riley) #1

Hello-

I am using FreePBX Distro 14 /w Endpoint Manager and Grandstream phones. The phones and the PBX are all on the same LAN. I am trying to get HTTP/HTTPS provisioning working and I’m not having any luck.

In the global settings of EPM, I have enabled HTTP & HTTPS provisioning in the Provisioning Protocols section of the System Admin modle and the HTTP provisioning port is set to 84 and the firewall zones are set to Other & Internal. The provisioning protocol in the template is set to HTTP.

I have created a device in EPM for my test extension and the config file appears to reside in /tftpboot/MYMACADDRESS.cfg

In the provisioning field of my Grandstream device, I have set the config type to HTTP and the Provisioning Server to MYIP:84, I have also tried http://MYIP:84 however, when I click provision now, the phone does not grab a config. Here is a screenshot of the config I have set: https://pasteboard.co/I12iwH0.png

I took a packet capture of the phone during the provisioning process and I see an HTTP GET from the phone, followed by a 401 UNAUTHORIZED from the PBX.

I have ensured there is no option 66 set on the network to interfere with the provisioning process at this point as I want to make sure I have this working before I attempt Option 66.

When I do a tail -f /var/log/messages, I don’t see any activity and a netstat -tuplen shows port 84 is listening on IPv6 but not IPv4, which seems like it may be an issue: https://pasteboard.co/I12h8Zl.png

Could someone help point me in the right direction as to why HTTP/HTTPS provisioning isn’t working with EPM in this scenario? Thank you!


(Kenny Riley) #2

My issue was resolved by setting HTTP authentication to NONE in the Provisioning Protocols section while I was testing this. I am going to secure it with HTTPS auth long term but wanted to get the basics working, which I have. Thanks anyhow!


(Lorne Gaetz) #3

Prov URL with credentials looks like:

http(s)//name:password@host:port