EPM Generates Truncated Config Files After Upgrade

We recently upgraded to FreePBX 16.0.30 and have EndPoint Manager 16.0.71, which is fully licensed. Our Grandstream GXP2135 phones that have already been provisioned continue to work. However, when I try to provision a new phone with the Extensions module and EPM, it generates two config files in /tftpboot, one named with the MAC address, the other named cfg+MAC address. The first file is as expected, but the cfg+MAC file is truncated significantly compared to the files that were generated for the working phones before we upgraded. Here is an example of the truncated file:

▒▒▒▒t▒}<)

0=P64 = CST6CDT
&P64=CST6CDT&P72=1&P78=1&P79=101&P81=1&P91=0&P99=0&P103=1&P129=0&P130=0&P145=0&P186=0&P191=0&P192=&P193=1440&P194=2&P196=111111&P207=&P208=0&P212=0&P237=137.22.208.12:69&P271=1&P446=1&P6768=&P6769=&P2989=&P2990=&P2993=&P2994=&P20719=0&P6767=0&P2997=&P2998=&gnkey=0b82

We have largely ruled out networking and TFTP issues as everything on that front seems to be behaving as expected. The config file itself seems to be truncated or corrupted, so the phone will not apply it. This appears to be something going on with EndPoint Manager not generating the files correctly.

We tried upgrading EPM via the GUI but received the message “Enabled; Not available online”. We also tried downgrading via command line but it was not available there either. We are willing to downgrade if that fixes the issues, although we are not sure how to do so.

Any thoughts?

Welcome to the forum @zkrodel!

This looks to be this issue [FREEPBX-23870] EPM V16.0.71 Creates 1KB Grandstream files - Sangoma Issue Tracker

resolved in epm ver. 16.0.72 and up. If you’re unable to update, that might be becasue you’re maintenance period has expired, see this wiki page for renewal instructions: How to Renew FreePBX Commercial Modules Maintenance - Sangoma Portal/Store - Documentation

Our maintenance period shows a 2044 expiration date with updates and support until 2020-11-22. However, we updated EPM to 16.0.71 from an older version about three weeks ago. We did upgrade from FreePBX 15 to 16 at the same time. How did the update work then but not now? Screenshot: