EPM Firmware Updates


Running the latest version of FreePBX and have commercial EPM, when managing the latest firmware for Grandstream in the case of GXP-2170 it shows Firmware v, however there are 5 newer versions, with the last being
In trying to resolve some re-registration issues, I’m being told to use the later versions, when do these get updated?
Is there a manual procedure I can run?


Thank you!
I will try that to at least test the situation.

Is there a schedule where Schmooze will update firmware and such?
Based on how many versions behind that brand appears to be, it feels a little like it has been neglected.
(Not trying to be negative)


Direct method not working.
I may be missing something so here is what I have done.
I - Dragged 0.00 to firmware slot 2
2 - uploaded the grandstream firmware file into the /tftpboot/grandstream/2/ folder
3 - made sure it was named gxp2170fw.bin just like slot 1
4 - confirmed the default version file was in place.
5 - went to a template for a test phone, applied firmware 2 slot to the firmware and rebooted.
Nothing ever happened from an upgrade perspective.
6 - erased phone trying to force a change - no different affect.

I do see the phone connecting and showing this: - - [20/Jun/2018:19:19:28 -0400] “GET /images/formatted/bg-grandstream-GXP-2170-GrandStream%20480%20x%20272.jpg HTTP/1.1” 200 42156 “-” “Grandstream Model HW GXP2170 SW DevId 000b863aa99b”

I then decided to manually edit the version file and created this:



I made sure file was named the same convention as in folder 1 which is maintained by FPBX.

reboot the device / wipe out the device…
It looks like the same information was requested from the http request as shown above and in the end no firmware upgrade.

any assistance or direction is appreciated.

Something with your phone is not requesting the firmware based on your logs.

Should I leave the version file as default or edit it like I did?
I will try with a brand new phone and I’ll downgrade it intentionally in order to confirm.

That log entry I thought told the version of the current firmware?

I have upgraded this phone recently by hand and the PBX downgrades it when it reboots.

Thanks Tony!

The version file is just for EPM to display in EPM the versions. The phones know nothing about it nor don’t they look or care about it.

1 Like

Thanks, I’ll post my findings with another phone of the same model, and I’ll remove my settings and re do them to insure I’m not changing anything which may cause an issue.


I went through the entire process again making sure everything was clean.
I removed firmware references and files for grandstream by removing values from slots.
Created firmware 1 slot with 0.00
Downloaded firmware for the gxp-2170 again, put the file into the slot 1 folder under grandstream.
Chowned the file to be owned by asterisk:asterisk.
Made a brand new template, assigned it to a brand new gxp-2170, assigned it firmware slot 1.
Force erased the phone.

The phone came up, had a different picture to help me identify that it used the right template, registered the extension and worked as expected ( from a phone perspective ), however no firmware upgrade was performed.

I see the phone talking to the PBX via HTTP for provisioning: - - [20/Jun/2018:23:29:14 -0400] “GET /cfg000b82cd3ced HTTP/1.1” 200 16818 “-” “Grandstream Model HW GXP2170 SW DevId 000b82cd3ced”

I took an additional step and downloaded and tried to use that file and it never tried to perform an upgrade.

To go the extra mile, I manually downgraded the phone and as you can see here, it connected and registered: - - [21/Jun/2018:00:07:02 -0400] “GET /images/formatted/bg-grandstream-GXP-2170-GrandStream%20480%20x%20272%20DTC%20VW.jpg HTTP/1.1” 200 58189 “-” “Grandstream Model HW GXP2170 SW DevId 000b82cd3ced”

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.