EPM doing nothing to Sanoma phone

I am wanting to play around with Call Parking, with a S700, and some other Sangoma model of phones I have here from this: Call Parking

I created a new extension (2004) for the S700 then registered it by putting the credentials in the telephone through the web interface.

So then I create a a new “test” template following the guide located here: EPM-Admin User Guide

EPM is showing 2004 is being used by the template “test.”

Following the Call Parking guide, ended up selecting “Save, Rebuild Config(s), and Update Phones” then pressing the “Apply” button; nothing happens except for the activity icon in the browser starts moving, then stops.

Extension mapping clearly shows EPM recognizes the telephone, and shows the MAC address, and a IP address status of 6ms (note: Clicking on the “Force Reboot of Phone” does function).

Any ideas on what is going on?

The Sangoma phones can update their configurations without rebooting. It sounds like you are expecting them to reboot.

1 Like

Actually I am expecting the phones to display the Call Parking on the correct buttons I have assigned (Line 10, and Expansion Button 2), hence the reason for this thread.

Thanks for responding, though.

Okay,well one might have led with the actual issue at hand. lol :slight_smile:

So you are setting up the XML App for Call Parking in your Sangoma template under models, Correct? And you don’t see anything on the phone for call parking after Save and Update phones.

Well, if I am following the guides (especially the Call Parking) and I am reporting …"nothing is happening."
So yes…it is not getting setup per what the guide is showing.

Are you running the latest firmware on the phone?
Have you factory reset it and let it provision again?
Does anything else provision on the phone? Like Lines, other XML-Apps and BLF buttons? If so can you move those around?

This is the firmware I have:

Product Model S700

Firmware Version BOOT– 11:10:00)
IMG– 14:14:00)
ROM– 14:14:00)
DSP–9.0.3(Patch 1.0.0)

Factory reset? It’s new out of the box, and all I have done to it is register, and update the firmware,

There is nothing else provisioned, and I cannot add anything.

Okay firmware is new. What I was referring to is in the template setup lines 1 2 and 3 with line keys, then 4 and 5 with blf keys (they can be fake) then push it to the phone. Does the screen change? Maybe add the transfer to vmail xml app to the phone too and see if that works. Just to make sure the phone is communicating properly.

By default, the template has Intercom for line 4, but nothing is showing up for line 4. I have tried changing it also to Parking, a BLF, and the vmail-xml transfer with no changes at all.

Sounds like you never told the phone how to reach the PBX for config files. Your first post states you logged into GUI of phone and setup the the extension. That is not correct. You need to follow the wiki on configuring the phone in EPM. You need to tell the phone how to get it’s config file the first time.

From my experience of using OSS Endpoint Manager, all I had to do was to make sure the telephone was registered to the system and could then make changes remotely.

I so followed your advice and was able to get it functioning however, the default password of “admin” was changed to something else in the process, and I no longer have access to the web interface. Any ideas on that?

Thanks for responding all.

If provisioning with commercial EPM, the admin password is as set in Endpoint Manager, Global Settings. Default is 222222 (which should be changed).

Ah, yes! I missed that. Thank you kindly!

1 Like

OSS never worked that way. The phone has to know how to reach the PBX the first time for configs. Their is no way around this.

1 Like

So I am not sure if he is still having this issue however… I seem to be having the same one. I have setup the new SNG7 with latest updates. Everything appears to be working just fine. I created templates for the S700 phones and setup 2 extensions. Mapped them and they configured 100% just fine the first time. I just setup a few more features and went into the template Models and changed a few lines around and added some more. I saved and Updated Configs (which happened in about 2 seconds. The little gear doesnt turn for 10-15 seconds like it normally does) and then Updated Phones and nothing happens. I go to Extension Mapping and “Force Check” nothing. However as the OP said Force Reboot does work… This isn’t my first rodeo, I know its right. lol. What can I do get info for you?

Also all updates are completed. None are available for download on main stream. Not running Edge.

@tonyclewis sorry to tag you on this, I am just wondering if this might be a bug. Again this is a clean install and the first provision worked without issues, as well it listens to the reboot command. I’m just not sure if its pushing the config or maybe not rewriting it. I even rebooted the phone and still no updates.

This tells me you don’t have you phone setup to reach the PBX for config. In the template you need to make sure you have provisioning protocol setup correct.

You can open a support ticket for additional assistance if you want.

I went into the phone settings and put a TFTP IP address of a local machine into my phone. Next time I will try the Sangoma provision.

I’ll check out the provision setup. Pretty sure I used http provisioning and that’s what I have setup but I probably have a typo somewhere. This is only my test bed not a production system.

Thanks Tony.