EPM - Digium Phones will not provision

Having a issue with trying to use the endpoint manager to provision digium phones, in this case I am using a D70. The D70 seems to pull the configuration correctly however when it goes to get firmware it cannot pull the firmware it seems. I get an error saying “the firmware update failed” and when I look in the apache logs I see the phone trying to pull a non existent file:

[Mon Jun 26 08:38:27 2017] [error] [client xx.xxx.xx.xx] File does not exist: /tftpboot/digium/N

At this point I cannot get the phone to move past this at all, the phone will not even start up unless it can get to firmware it seems. I do have a sangoma and aastra phone as well which both seem to work fine with EPM. I can get this phone to register to a system that uses dpma though with no problem.

What I have tried to do to get around it (without any success) is:

  • I’ve tried to set the firmware slot to none in EPM
  • Factory reset phone with every change I made
  • Tried to copy every firmware update for these phone from another pbx to this pbx into various directories (/var/www/digium_phones and /tftpboot/variousdirectories)
  • I tried deleting and readding the firmware from EPM
  • I tried disabling the firewall and fail2ban to test if this would help

I’m not sure what else I can try with this to get it functioning.

Other info:
Asterisk: 13.4.0
Freepbx: 13.0.192.9
EPM: 13.0.100
Provision Server Protocol in EPM for digum template: HTTP (the only option)
Destination Address: External address - the system has a external static IP
HTTP Provisioning Port: 83

Port 83 is open and reachable:

[[email protected] tftpboot]# netstat -tunap|grep :83
tcp        0      0 :::83                       :::*                        LISTEN      1518/httpd

I can telnet to this from my local machine:

telnet xx.xxx.xxx.xxx  83                                                                                                 -
Trying xx.xxx.xxx.xxx...
Connected to xx.xxx.xxx.xxx.
Escape character is '^]'.

I’m not sure what else to try, does anyone have any suggestions?

Well I got the phone to pull the firmware by placing the current firmware in /tftpboot/digium/N/D70.eff
However the phone will now just boot up grab its config, download the firmware and reboot over and over.

I can still connect it to a different server that uses dpma and it works, it just will not boot up using EPM.