EPM cannot edit basefiles still


Ive been fighting with EPM not being able to edit basefiles with a couple of versions now across multiple installs, i keep reading the bug is fixed but still there. I have also tried edge on 3 boxes for the endpoint module but still get the error when i try and change and then update/rebuild the config files. Here is the error…

Undefined index: user

im starting to get really depressed now about this im wasting so much time, support ticket was pretty unhelpful so running out of ideas, any suggestions appreciated

edit… i have noticed also its only when there is extensions assigned to the template, if i create a new or clone the template with no extensions assigned i do not get the error

Nathen I feel for you. I’ve been there many times before.

So tell us about your setup. What ver FreePBX what ver of epm? What phones u working with??

And just to be clear your working with the FreePBX district and you are using the commercial epm??

Also just saw this also

Nathan look at the link I posted above @qwell just updated it. Re download the latest in edge and you should be good. He just made your night.

Hi Frank.

All sites we run the paid commercial version of EPM. We generally run a mix of polycom and yealink phones. ive enabled Edge and run all updates for system and modules :slight_smile:

EndPoint Manager

i dont know if it has anything to do with it but the common things here seem to be when a duplicate a base template to a new name and then add some custom entries to the basefile after the extensions have been assigned to the template…my only solution at present is to continue to make any changes to the original template, clone it off again, re-assign the extensions and reboot the phones, then delete the template given me trouble… very long and tedious way around it.

Would you mind opening an issue at issues.freepbx.org? I can certainly try to reproduce it using the steps you’ve provided. That’s definitely useful information.

sure thing ill do it now

what ive also been able to do is since re-creating the template and re-assigned the extensions, its now as before giving the same error

Undefined index: user

so i can confirm it only happens after the extensions have been assigned, this time around i have only assigned 2 extensions

Any update guys? I have logged issues, waited, give as much info as i can… im getting really desperate now, have almost a dozen sites with paid epm modules that i cannot edit basefiles without massive muck around

There was a release made to fix the issue you reported (http://issues.freepbx.org/browse/FREEPBX-14352) about a week ago. JIRA should have sent you emails for the updates. That fix is available in 13.0.105.