EPM Basefile Issue

Just set up a new system using the commercial EPM (this is the first system we have tried it on – always used the OSS EPM until now.)

Everything seemed to be moving along OK until today. I have had to make a few customizations through the basefile editor. I made several changes yesterday and today with no incident.

Then, this afternoon, I made another change in the basefile editor (override a Cisco parameter) and all of my phone configs ended up hosed. It appears now that if you customize ANY parameters in the basefile editor, then ONLY those parameters show up in there (and in the phone configs.) All non-customized parameters disappear.

If I check “Remove” next to any of my customized parameters and submit the changes, all of the stock ones come back.

This did not happen until this afternoon. I want to say it may have started after upgrading the module to the latest version.

I’ve tried downgrading to the previous version as well as completely uninstalling and reinstalling it. Same result.

Any ideas? Am I just missing something here? Doing something stupid? (Hopefully so.)

I know that we have customized all the Cisco basefiles to I am not sure what you are doing wrong.

All I can do is tell you from experience it has worked.

I believe you. Let me try to explain it a bit better (last night was probably NOT the time to be posting as my brain was fried from spending most of the day on this.) :slight_smile:

When I first installed the commercial EPM module, I created a new template called “ciscoeasterntz” (named such because this system is going to have phones in several time zones, and if things in the commercial EPM work like the OSS EPM does, you end up needing a template for each time zone.) I filled in all of the relevant settings (server IPs, etc.) for the template. I also enabled SPA504G (then configured the line keys) and SPA2102 for the template. So far so good.

I got a test phone online using this arrangement. It became obvious that there were several parameters that needed to be tweaked, though. This is when I started tinkering around with the basefile editor.

I was able to customize quite a bit of the parameters in the basefile editor. Anything I changed ended up with a check in the “custom” box (as it should) and it saved. Anything I did not customize still remained in the basefile editor, without a “custom” check, and the default value remained.

At some point yesterday afternoon (I want to say this was after upgrading the commercial EPM module to the latest version), the functionality of the basefile editor broke. I made a change to one of my custom parameters, saved, re-built all of the phone configs, and noticed that the phone configs were very small. None of them had the proxy address, nor the SIP credentials, etc. Turns out the only parameters in the phones’ configs were ones that I had customized in the basefile editor.

I went back to the basefile editor and noticed it loaded much quicker, and that only the customized parameters were showing up. All of the default ones were gone.

So then I end up with a bunch of potentially broken phones.

I chucked it up to clicking on a wrong button or an anomaly, so I created a new template and re-did my customizations. Same thing.

I even created a new template, then customized one parameter. Again, once I did this, that was the only parameter showing up in the basefile editor, and in the phone configs.

If I check “remove” for that custom parameter and save the changes, then all of the default ones come back (and my custom one goes away.) I assume if I went through my other templates (with several customizations) and deleted those customizations, then the default parameters would suddenly re-appear.

This did not happen before the upgrade. I can’t say for sure that it ever worked correctly after the upgrade to to be honest. But I didn’t really keep track of what happened pre/post upgrade (since I didn’t expect the upgrade to break everything.)

I did manage to get the .tgz file for the previous version (.70) and installed it. No change. I also uninstalled completely via module admin, then removed the endpoint directory from /var/www/html/admin/modules, and re-installed the latest version via module admin from the online repo. Same problem.

I guess my next step is to completely uninstall, then remove that directory, and try installing .70 from the .tgz and see if that works.

But, at this point, I am at a loss. I would use the OSS EPM module (which we’ve always had success with in the past) but it does not seem to support HTTP provisioning (the option is there but it doesn’t work.) The customer has some type of Juniper router (never dealt with those before) that apparently have trouble passing TFTP traffic. When we attempted to move them from our old legacy system (which uses HTTP provisioning) to the new FreePBX systems, the phones wouldn’t provision. I knew the commercial EPM would probably do HTTP just fine, so we went for that solution instead.

Any ideas would be appreciated. I’m going to go try installing .70 fresh just to see if that helps or not in the meantime.

FWIW, I just uninstalled again via module admin, deleted /var/www/html/admin/modules/endpoint, then installed from the .70 .tgz file. Issue persists.

I just tried this same process again but installed and everything seems to work fine. Possible bug?

1 Like

Sounds like a bug. Can you open a bug report so it can get fixed