Endpoint Manager Update

Hello,
I am getting an error updating Endpoint Manager which is now disabled until it get’s updated.
EndPoint Manager14.0.2.135; Disabled: Pending Upgrade to 14.0.2.138
Tried to uninstall (so I could reinstall) and:

  • EndPoint Manager cannot be uninstalled because the following modules depend on it:
    * restapps Please disable those modules first then try again.

I cannot find this ‘restapps’ module anywhere.

This was one of about 8 modules I updated using fwconsole ma updateall.
Once I got the Apply button, I click that, and get the error!
exit: 255
Unable to continue. Call to undefined function FreePBX\modules\endpoint_apiApp() in /var/www/html/admin/modules/restapps/Restapps.class.php on line 1458 #0 /var/www/html/admin/libraries/Composer/vendor/filp/whoops/src/Whoops/Run.php(383): Whoops\Run->handleError(1, ‘Call to undefin…’, ‘/var/www/html/a…’, 1458) #1 [internal function]: Whoops\Run->handleShutdown() #2 {main}

Anyone else seen this with EPM?

I ran CMD fwconsole ma install endpoint and got the error:

[[email protected] ~]# fwconsole ma install endpoint
Checking database tables…Done
Migrating tables as required…Done
Checking Settings and Defaults…
In install.php line 3076:

Invalid argument supplied for foreach()

What is the error you get from:

fwconsole ma install endpoint

Invalid argument supplied for foreach()

Try rolling back with:

 fwconsole ma downloadinstall endpoint --tag 14.0.2.97

That seemed to work!
Rolled it back to .97
Should I run a GUI update for EPM only, or fwconsole ma updateall ?

1 Like

Either will work the same way. This was not caused by something you did, there is an EPM bug in the version you were attempting to install:
https://issues.freepbx.org/browse/FREEPBX-18032

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.