Endpoint Manager unable to upgrade leading restapps to be unable to upgrade, after FreePBX 14->15 Transition

fwconsole ma updateall
No repos specified, using: [standard,extended,unsupported,commercial] from last GUI settings

Module(s) requiring upgrades: restapps
Upgrading module 'restapps' from to
Downloading module 'restapps'
Processing restapps
Verifying local module download...Verified
Download completed in 1 seconds
Detected Missing Dependency of: endpoint 15.0.25
Downloading Missing Dependency of: endpoint 15.0.25
Processing endpoint
Verifying local module download...Verified
Module endpoint successfully downloaded
Installing Missing Dependency of: endpoint 15.0.25
Create symlink...Done
Checking database tables...Done
Migrating tables as required...Done
Checking Settings and Defaults...Done
Generating Configs...Done
Downloading Firmware...Done (Background)
Generating CSS...Done
Installed Missing Dependency of: endpoint 15.0.25
Unable to install module restapps:
 - <strong>EndPoint Manager</strong> module version 15.0.25 or higher is required, you have
Updating Hooks...Done
Chowning directories...Done
All upgrades completed successfully!
Updating Hooks...Done
Chowning directories...Done

Also, I get an error message telling me I have to do a reload --verbose in the console every time I hit apply settings, but once I do reload verbose in the console it’s fine… so I guess reloading in the webUI is broken. No idea if this is related.

Is your maintenance current on the EPM module?

Are you even using restapps? if not, delete it.

fwconsole ma delete restapps
fwconsole reload

But that will still not resolve the issue of your EPM not being able to update. @lgaetz gave you the answer there.

It seems you are correct, I had no idea the 25 year license did not include updates. This is an issue because I can’t load the Endpoint Manager now that I’ve upgraded to 15, even though I did the fwconsole chown as requested. (I have seen errors like this on other pages on the pbx but can’t seem to find them at the moment.)

My concern is, what if buying the upgrades doesn’t fix it, and I’ve paid for nothing? If I get remote support included to get it working, that changes things.

The whoops error is a permissions issue which should be fixable with:

fwconsole chown

Free bug support is included with commercial module purchase/renewal.

Wow, that’s strange, I did chown earlier (I could scroll up in my PuTTY session) and it worked but didn’t fix the issue, and now that I’ve removed restapps and done it again, it did fix the issue. Thanks!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.