Endpoint Manager + Sangoma Phones, problem


Warning: Noob alert :slight_smile:

I’m having an issue with Endpoint manager and zero touch installation on to Sangoma S300 and S500 phones. I’m running them all internally, on the same vlan as the PBXs internal address, the network scan picks up the phone as expected and i select the template (which has been edited with the details of our PBX) and phone model.

The phone then goes into the endpoint manager list, turns green, shows the extension name/number and brand/mac address correctly, but the IP addresss field stays blank. If i then login to the phone i see that it has all the details correct from DHCP, but the settings in the template aren’t being applied.

If i then select one and tell it to save, rebuild and update, then i get this line in the log (and nothing else):
[2016-07-22 09:38:38] WARNING[14736] chan_sip.c: Purely numeric hostname (500), and not a peer–rejecting!

I understand what that’s telling me…i think, but i don’t understand what i need to actually change. Help! :slight_smile:

EDIT: I’ve also tried logging into the phone, editing the autoprovision address/details manually and telling it to auto provision that way, but it still doesn’t play ball. I don’t know where to find more detailed logs about what’s happening either?

EDIT2: The extensions in question are all pjsip, if that matters…I think that’s what i should be using for internal extensions? (I did warn you i was a noob at this!)
Also another weird thing is that the global settings have applied, because the admin password to the phones is what is should be…
EDIT3: In addition, manually configuring the sip server, userid and authenticate password registers the phone correctly, and it all works fine, so it’s only the endpoint mapping/zero touch configuration deployment to the phone having an issue, just cannot for the life of me work out why it’s not working.

I think i’ve fixed it, reset the global admin password back to the FreePBX default and now it’s working.

I had set an alphanumeric password as it seemed the Sangoma phones were happy with that (and they’re the only VoIP phones we have) but it appears to not be the case. Still need to test another numeric password different to the default though…