Endpoint Manager - Polycom Phones - TFTP

Hi the distro installation is really user friendly and installs without error!

I am able to get my Polycom 331’s and 550’s connected to FreePBX but im not sure how to get the phones to provision them. I used the following settings in the phones server options…

Server Type: Trivial FTP
Server Addr: 192.168.5.230 (PBX Static IP)
Server User: Mike (PBX Admin name)
Server Password: ***** (PBX Admin Password)

I set option 66 on my DHCP server to 192.168.5.230

I used a port scanner and port 21 is open

I looked at the files in root/tftpboot, i noticed there is a config file named after my phones MAC address’s for each phone so Im pretty sure the Endpoint Configuration is working properly. There is also sip.cfg and all the other files necessary to provision the phones. When I press Rebuild Configs for Selected Phones with the option Reboot Phones checked, they all reboot.

How can I tell if tftp is running correctly on the PBX server? Also am I using the correct User and Password to connect to tftp? I could not find anywhere in the PBX to create FTP users or set permissions for access.

Thanks for your help!

run

reboot the polycom. If there is nothing in the logs then you have a misconfiguration error with tftp

Which is why I am writing my own tftp server for endpoint manager.

I see 2 log files for each phone named after their mac address in root/tftpboot/logs. One is macaddress-app.log and the other macaddress-boot.log The log files are blank.

TFTP does not use a username or password. Leave those fields blank on your server.

Good to hear. Let us know if you have any other issues.

Thanks guys! I was able to provision 2 331 phones last night simply by adding them to the EndPoint Device List, changing the server settings in the phones to my pbx server address and after rebooting the phones, they downloaded new software from boot server, updated and worked no problems. Now today I follow the sames steps, same model phones, but there is a “error downloading” message dispayed on the phones during boot. Not to be confused with the “cannot connect to boot server…” message that I was getting before. I have rebooted the server a few times, confirmed my settings in the polycoms but not having any luck. Any ideas would be much appreciated, thanks!

Im not certain this problem is specific to the new distro. I found some posts to read on tftp issues in the general section of the forum, I imagine the answer is in there somewhere. I will try everything I find in the general section first and post results.

Look at tftpboot/logs and see if the polycom has written there. if not chmod 77 the logs dir then reboot the phone and see what it says

Ok - I uninstalled the firmware sets. Then I uninstalled polycom brand in the configuration manager.

Then I clicked “check for updates”.
Then I enabled "polycom 430"
Then I installed the firmware for 430.
Then I went back and rebuilt the configurations.

Still same results in the /tftpboot directory.

Clearly I am doing something wrong since I am a beginner with this.

Also, I have polycom 550 and 430 phones. Sounds like I can’t provision them together?

Thanks!

You can once I get around to fixing #5067

They recently removed the 430 from the list of firmware 3.3.1 supported phones and since I don’t have a 430 it’s been quite a pain.

Can you email me so we can talk directly? andrew(dot)nagy (at) the159(dot)com

You need to uninstall the reinstall the Polycom brand. The 430 is no longer a part of "SoundPoint/Station/VVX In-Production Models "

Then you need to install the firmware for just the 430 from Endpoint Manager

PS The freepbx distro version number is meaningless to me. Endpoint Manager works on all distros.

cp /tftpboot/2345-11402-001.sip_325.ld /tftpboot/2345-11402-001.ld

I installed firmware for the following two categories
SoundPoint IP 430 [430]
SoundPoint/Station/VVX In-Production Models [320,330,321,331,335,450,550,560,650,670,5000,6000,7000,1500]

I din’t see a file with that name in /tftpboot

Just now I uninstalled all firmware using the end point manager and just installed for SountPoint IP 430.

I get these files -

[[email protected] tftpboot]# ls -l *.ld
-rw-r–r-- 1 asterisk asterisk 601016 Apr 28 10:52 2345-11402-001.bootrom.ld
-rw-r–r-- 1 asterisk asterisk 609364 Apr 28 10:52 2345-12450-001.bootrom.ld
-rw-r–r-- 1 asterisk asterisk 619156 Apr 28 10:52 2345-12500-001.bootrom.ld
-rw-r–r-- 1 asterisk asterisk 619156 Apr 28 10:52 2345-12560-001.bootrom.ld
-rw-r–r-- 1 asterisk asterisk 619156 Apr 28 10:52 2345-12600-001.bootrom.ld
-rw-r–r-- 1 asterisk asterisk 619156 Apr 28 10:52 2345-12670-001.bootrom.ld
-rw-r–r-- 1 asterisk asterisk 3093771 Apr 28 10:52 2345-17960-001.bootrom.ld
-rw-r–r-- 1 asterisk asterisk 1654167 Apr 28 10:52 3111-15600-001.bootrom.ld
-rw-r–r-- 1 asterisk asterisk 2458832 Apr 28 10:52 3111-40000-001.bootrom.ld
-rw-r–r-- 1 asterisk asterisk 71524312 Apr 28 10:52 sip.ld

The cfg file for the phone has this line -

    <APPLICATION_SPIP430 APP_FILE_PATH_SPIP430="sip_325.ld" CONFIG_FILES_SPIP430="0004f205f6ba_reg.cfg, server_325.cfg, phone1_325.cfg, sip_325.cfg"/>

And it also gives an application error (after I put the firmware in the dir myself). To get the application error to go away, I had to remove the _325 from the cfg file names.

[[email protected] tftpboot]# cat /etc/asterisk/freepbxdistro-version
1.8.1.2-4

I tried to configure my first phone with the endpoint manager - so I may be doing something wrong. After it booted and downloaded the firmware it failed and said application not found.

It was not writing logs until I followed the advice above and did the chmod on the logs directory.

According to the logs, the phone is looking for:
tftp://192.168.1.20/2345-11402-001.sip_325.ld’ from ‘192.168.1.20’
ane then
tftp://192.168.1.20/sip_325.ld’ from ‘192.168.1.20’

neither of which exist in the tftpboot directory.

Let me know if there is any other info that can help or if I should file a ticket.

Working great now after removing the username and pass! Thanks!

Just wanted to thank Andrew for helping me solve this offline.