Endpoint Manager Issue: Taking 18 seconds to complete call

endpoint
Tags: #<Tag:0x00007f702ceab750>

(Ben Itse) #1

Hello,

We purchased the Endpoint Manager module to be able to configure Grandstream phones. We have successfully configured one as a test. However, it doesn’t matter if placing an internal or external number, the call takes 18-20 seconds to complete. Every time. All settings seem good. I don’t know what it could be.

So, as a test, we configured two more Sangoma phones using EPM and we are having the same issue!

Can someone please shed some light into this?

We are running FreePBX15 with all the latest updates installed.


(Dave Burgess) #2

Could you be more specific about this time line? When do you start timing? Are you using a ‘dial send’ feature (like “#” at the end of your dialing, or use the ‘send’ button to send the call)?

Do you have a dialplan set up in the phone, and if so, would you share it?

Have you checked the /var/log/asterisk/full log to see how the system is handling the call? For example, if the server doesn’t pick the call up for 20 seconds, the problem is “before” the PBX. If it’s taking a long time to get the call through the PBX, that’s a different issue, and if the call is getting dispatched quickly but the remote phone isn’t recognizing the call until later, that’s a different issue altogether.

There’s lots of things it could be, from dialplan settings to a bad DNS server, so the more information you can give us, the easier it will be to get to the bottom of it.


#3

Does that 18-20 seconds also exist for calls only to the PBX (i.e. not another phone, but dialing - for example - the echo test - if you setup the misc destination for things like echo test that is…)?

I’d run a packet capture on the asterisk box and then load it into wireshark to get some idea of where the delays are. Something like: tcpdump -i eth0 -s 0 -w capture.pcap not port 22
would capture everything but ssh traffic in the file capture.pcap (assuming the ethernet device is eth0)…


(Ben Itse) #4

Thanks, @cynjut.

To answer some of your questions, we start the timing as soon as we finished dialing our number. This behavior occurs either doing an off-hook dialing, or pressing the send key through speaker, or dialing # after the number. And, it happens to either an external 10 digit number or internal 3 digit extension.

The weird thing is if we configure the phone manually with the same server (not using EPM), then everything works as expected. The call connects immediately.

We’ve checked and re-checked but we can’t see anything in the logs. The dialplans on the phone is the standard one. This happens on both Sangoma and Grandstream phones using EPM. It is worth noting we have SangomaConnect and Zulu both running on this particular PBX. Could that be causing a conflict?


(Ben Itse) #5

@nielsen - thank you for you reply. To answer your question, yes, it happens even when dialing to *43 to do an echo test. I’ll do a packet capture now to see what comes up.


(Dave Burgess) #6

To fall back to old knowledge - 20 seconds is about the amount of time it takes for a device in the FreePBX universe to fail to contact two DNS servers… If your hand-crafted config works and the one from EPM doesn’t, there might be a clue there.

Note that it might not be DNS - it could be some other thing that the phone is trying to do that your network just isn’t letting it do…