FreePBX | Register | Issues | Wiki | Portal | Support

EndPoint Manager is not creating additional lines with extensions


(United States) #1

I am using the EPM with yealink phones (t46g) and it will create only one line with account, even though in the template for the phone i set many more…

when it saves, updates and rebuilds phones, it will reflect all the other changes, but never add more than one line…

any ideas?


(Itzik) #2

Let me explain.

Per your screenshot, you set 5 line keys, but you associated each line key with another account.

Say you have extension 101 and you want 5 line keys for that extension, then you have to set all line keys to Account 1.

But if you want to have 5 different extensions on that phone, you’ll need to add them all in extension mapping, and specify which extension to use which account.

So it seems to me that you are just using 1 account, so all you need to do, is set them all to account 1.

A good place to start, is wiki.freepbx.org


(United States) #3

thank you for your response. after poking around i finally figured that out and your explanation was perfect…however, i do have this additional issue. when setting the mapping all to account 1 in the extension mapping, if i use line 4 for something like BLF and input as here:

after saving the configs, the yealink t38G phones return this in the respective DSS>>Line Key section of the phone.

when i look at the yealink T46G phones, they map correctly to extension 1 across the board and although there are the two * symbols in the extension field, it does not affect anything.

thank you again. i do not know if this is a yealink issue or EPM, but mapping seems the only culprit IMO…but what the hell do i know.


(United States) #4

Basically this issue:
https://issues.freepbx.org/plugins/servlet/mobile#issue/FREEPBX-11850


(Itzik) #5

As you can see this has been fixed.
Save and rebuild your config, then find your config file in /tftpboot and see if the config is correct, if it is then it’s likely an issue with your Yealink and you can try a factory reset.
If you don’t see there the right config and you are on the latest version of EPM, then you need to contact support.


(United States) #6

well, EPM is recently updated and the TFTP config files for the yealink t38G are incorrect after updating with EPM. My solution was to go to the basefile config for that model, Yealink T38G and setting the lines that are the issue of mapping the incorrect accounts. for anyone else looking for a workaround (like the previous gent who added the bug ticket )

set to this: linekey.5.line = 0 (or any line that you are having EPM insert a different account number from the GUI)

maybe someone will see and fix the EPM…

thanks again!

Cheers


(Itzik) #7

If no one reports it, it won’t get fixed.

support.sangoma.com