FreePBX | Register | Issues | Wiki | Portal | Support

Endpoint Manager Grandstream Can't make or receive calls


(Jjanuskey) #1

Howdy all,

Thanks for a great forum, I’ve found lots of very helpful posts here over the years. I’m hoping someone can help me figure out an issue I’m having with some of my Grandstream phones.

I’m having an issue provisioning both GXP2124 and GXP2170 phones with the Endpoint Manager (commercial). I have reproduced the same issue on multiple phones of each model. Phones work perfectly with the endpoint manager using any of the 1.0.7.xxx firmwares, but upgrading to 1.0.8.xxx or beyond (including the latest 1.0.9.135) results in a phone that is registered, but has no dial tone and can’t dial.

Phones show as registered to an account on the display and show up as registered in fop2. Making a call to the phone will trigger a missed call notification on the phone and send the call to busy voicemail. There is no dial tone and dial buttons are un-responsive.

If I clear the Endpoint manager generated configs from tftp, and do a factory reset, I can manually configure the phones and they connect to with no problems. This includes using call park and blf buttons. Everything works with manual config.

I tried exporting the config files from a GXP2170 and comparing them. I pasted to excel, sorted, put back into text files and ran a diff. There were lots of things different between the default config and the provisioned config. I’m not really sure where to look and was hoping someone has seen this or something similar and has a solution. One that I noticed was the dial patterns. Could that be the issue?

I’m a new user so it won’t let me upload the config files. Let me know if there’s a way I can add them.

I’m running a fresh and fully updated install with:
FreePBX 15.0.16
Asterisk 12.22.0
Endpoint Manager 15.0.19.15
Default Grandstream Base File

Thanks,
-John


#2

Paste your files at https://pastebin.freepbx.org and post the links here.
If the the forum rejects your link, replace the last dot with %2E, for example, change
pastebin.freepbx.org/view/fa3c7524
to
pastebin.freepbx%2Eorg/view/fa3c7524
which can be opened by pasting the text into the browser address bar, or using the right-click option to go to the selected URL.


(Jjanuskey) #3

Thanks for the response. Files are here:

https://pastebin.freepbx.org/view/5b794d84
https://pastebin.freepbx.org/view/0eb654aa


(Tony Guadagno) #4

fyi, I am also having this issue. After the firmware upgrade, pjsip show contacts show the phone as available but cannot make or receive calls.


(Byteguy) #5

We are running Firmware 1.0.9.132 on our GXP2130 and GXP2160 phones with EPM and no problems. I don’t recall any big issues when updating the firmware, although I vaguely recall having to make sure that the Line Keys in the templates for the phones was set to type Line and Account 1, while earlier versions of the firmware didn’t seem to mind if these were blank/default. We do have quite a few extr bits added to the templates in the basefile editor but that’s mainly for our own requirements as I recall.


(Novaworks) #6

Is there any update to this? I have tried adjusting the base files in the EPM to match the working configurations but so far nothing has worked. If not does anyone have the procedure (if any) to downgrade the firmware on the phones to one that does work with the EPM?

I’m running:
FreePBX 14.0.13.4
Asterisk Version:13.22.0
EPM: 14.0.9
Default Grandstream Base File

Thanks!


(Jjanuskey) #7

Setting any line key on the first screen of the phone to a line rather than blf, call park, etc… allows the phone to register and work. I tried putting the line key on the second screen and it didn’t work.

It’s annoying to give up a button, but I set the first button on all my phone models to:

Type: Line
Account: Account 1

The other keys are set to call park and blf as needed. This is working with the latest firmware (as of about a month ago) for GXP 2000, 2124, 2160 and 2170.

I hope this helps.


(Novaworks) #8

Thanks!