Endpoint Manager custome FW with Yealink


(Sentinel) #1

I am trying to upload the current FW. I use slot 1, 0.00 and it doens’t update. What is the proper process for custom FW with yealink?


(Philip Young) #2

What version is your Endpoint Manager at ? I’ve had issues for a long time where the directory wouldn’t create itself. I had to create it and then it worked. If that’s the case just make sure you create it cd /tftpboot/yealink/1 so you can upload your firmware.

This works https://wiki.freepbx.org/display/FPG/EPM-Admin+User+Guide#EPM-AdminUserGuide-InstallingCustomFirmware


(Sentinel) #3

I have created it and put the firmware in there and it doesn’t’ update. I run fwconsole chown to set permissions. When I copy it over and when I attempt and update, it’s actually erasing the FW in the 1 folder and the 2 folder and doesn’t update the phone at all.


(Philip Young) #4

What permissions do you see when you list the contents of the directory ?
This is what I’ve got :
-rw-r–r-- 1 asterisk asterisk 29320128 Nov 25 15:53 t46s.rom

How is your file named ? It has to be written in lower cases.

It is very strange that your firmware gets erased! I haven’t had this issue.


(Sentinel) #5

I solved this. I had to rename the rom to t29.rom not T29.rom or the stock name


(system) closed #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.