Endpoint Manager Commerical Error

When inside the Base file edit I modified the basefile and after I added it i get this error when I hit Save and Rebuild Config

Undefined index: _type

All other basefile edits worked just fine

I ran fwconsole chown and I got this error

filetype(): Lstat failed for /var/lib/asterisk/bin/getservices

I updated the modules and the error

filetype(): Lstat failed for /var/lib/asterisk/bin/getservices

went away.

But still have the other issue

Anybody have this issue before or should I create a Case with EPM support

I have it too…just now!

UPdate the module to 13.0.56

Im on EPM 13.0.61 is there another module i need to update?

run fwconsole chown are you getting the same error was getting

when i run that i dont get any errors. just tried to save and rebuild config and got the same initial error you were getting

Try to reinstall epm

Will I lose all my templates and settings?

I cant remember @xrobau

Reinstalling EPM is not likely to help. Since I am unable to reproduce on 13.0.71, you might try upgrading to the Edge version:

fwconsole ma --edge upgrade endpoint

Ok thanks for the tip. We actually opened a paid support ticket regarding another issue we’re having with EPM so maybe upgrading to that will be part of the fix anyway…thanks everyone!

Ok reviving an old thread here b/c it’s happening again. @lgaetz I ran that command b/c I was experiencing the issue with a certain template I was editing the basefile on. It fixed that. Now I am working on another basefile and I am getting Whoops\Exception\ErrorException
Undefined index: _type