Endpoint Manager (Commercial) Won't Install

I am having trouble getting commercial endpoint manager to install.
I think it is due to a botched or incomplete update of the module.

[[email protected] ~]# fwconsole ma install endpoint
Checking database tables…Done
Migrating tables as required…Done
Checking Settings and Defaults…

[Exception]
INSERT INTO endpoint_global (key, values) VALUES (‘legacyXML’, ‘Y’) – SQLSTATE[23000]: Integrity constraint violation
: 1062 Duplicate entry ‘legacyXML’ for key ‘key’::

ma [-f|–force] [-d|–debug] [–edge] [–color] [–skipchown] [-e|–autoenable] [–skipdisabled] [–snapshot SNAPSHOT] [–format FORMAT] [-R|–repo REPO] [-t|–tag TAG] [–onlystdout] [–willupdate] [–securityonly] [–sendemails] [–] []…

Looks like it. The syntax for that INSERT should include an “IGNORE” clause if there’s any possibility the database has already been updated. If you are brave, you can log into MySQL as root and enter “DELETE FROM endpoint_global WHERE key = “legacyXML”;”

There are all sorts of ways this could go, including doing the right thing and allowing you to continue or failing with some other problem in the database.

I tried removing the key. Hosed it further. The keys still still existed for endpoint even after removing and deleting the module.

I tried restoring a full backup. No luck. I tried your suggestion. No luck. Same result. Legacy-XML key gets regenerated each time.

Any help is greatly appreciated.

Well, I don’t know how it started working again, but it is.

I ran fwconsole ma --edge install endpoint and it installed a newer version of framework. ran the same command again (fwconsole ma --edge install endpoint) and it successfully installed endpoint without any sql error. I then installed restapps again. seems to be fine.
weird.

1 Like