Endpoint Manager - Basefile Edit Cisco


If I add any of my own XML settings to the basefile edit, phones can not provision.
As an example I want to control the ringtone which is being used.

This is the XML I have used previously in OSS EPM.
Once I saved it the phones stop provisioning, I verified that the XML was correct by going to the web interface of the phone using ip.address/admin/spacfg.xml and the result for the ring tone was the same as above.

I tried the parameter as both Default_Ring__1__ group=“Ext_1/Call_Feature_Settings” and as just Default_Ring__1__ either way, once I add the setting the phones can NOT provision and just get stuck.

Basefile edit does show IN RED correctly the above XML that I added.

I’m running FreePBX 12.0.9

Any suggestions appreciated.

I have the same issue, I set the default ring tone using OSS EPM with:

<Default_Ring__1__ ua="na">5</Default_Ring__1__> 

Basefile Edit chokes on:


Appears to treat it as a variable and translates to


in the phone specific xml file which causes the configuration to break. You can save the parameter directly in the specific phone config and the phone will boot and use the correct ring tone, but that is not a solution since it gets overwritten by EPM if the configuration is changed. I also noticed the phone reboot function does not work and is a real pain to be forced to rebooting at the physical phones. I switched back to OSS EPM since it works.

Anyone, I need to put several parameters in place including to tell the phones not to provision or reboot during the day.


Open a bug report at issues.freepbx.org

As far as your issue the X is the problem as we use X to define a variable so its stripping a __ thinking its a variable.

Thanks Tony, will do…

Hi Shauberg,

You can follow http://issues.freepbx.org/browse/FREEPBX-8309 for a resolution…

Correct entry is as follows:
Default_Ring__1__ ua="na"
with two _ after Ring and 1

With that and version (yes it was a bug that needed to be fixed), the setting works and the phones do not endlessly reboot.

I am using SPA509G phones with firmware 7.5.6a.

Default_Ring__1__ ua=“na” is required to set the parameter. Default_Ring_1_ ua=“na” doesn’t cause the phone to reboot endlessly or not provision, but doesn’t set the parameter.

The quick response on this is much appreciated, thank you!

EPM solved this, great job!