Endpoint/Aastra Edit Global Settings Overrides issue maybe?


I have a working system (mostly).

I have FreePBX on :slight_smile:

If I set the IP address under Endpoint Configuration Manager to the, it creates suitable aastra.cfg and $mac.cfg files for all my local phones.

Then I go into the Endpoint Template Manager and select the templates for two remote phones, and I do the Global Settings Overrides. I set the IP address to my dynamic dns name for that one phone only. Now I generate new configuration files and instead of my local IP address, I have my FQDN in there. Now if I reboot the local phones at work, they only register on LINE 1, not on 2 or 3, because they’re trying to use the FQDN on Line 2 and 3.

Basically I thought the way this should work is that the Global Settings Overrides would leave the original aastra.cfg alone, and put everything necessary in the $mac.cfg. So a remote phone would load the aastra.cfg file with the IP address, but then the $mac.cfg would come in and change the registrations for Line 1, 2, and 3 and set them using the FQDN.

If I reverse things and have the remote phone reboot with the aastra.cfg that was generated for the local phones, it only registers on its first line and the other two lines are trying to register to the local IP address of the server (which the phone cannot see because the server is remote).

Yes, I could establish a VPN to “fix” this. But I’d rather be able to basically take a phone on the road with me and run it on someone else’s network. The phones get their configs via FTP and if I could work on the registrations on all three lines, it would work great.

Another option would be to create two folders within the tftpboot folder, one local, one remote. The aastra.cfg that gets generated would be copied into the suitable folder, along with the appropriate $mac.cfg files. But will I remember what I’m doing in six months if I want to make changes (I doubt it).

Another real possibility is I’m not configuring this correctly. The phones show three lines in the Endpoint Device List, but I can only assign a single line. Is there a way to tell Endpoint to assign all three lines to an extension such that the $mac.cfg will have the suitable line assignments?

Any thoughts or comments would be most welcome!

I think I need the code within the {line_loop} section to run three times, once for each line on the phones. I suppose I could edit the $mac.cfg, but I’m hoping I’m looking at this wrong and maybe there is a way to accomplish this without playing around with the file.

Yep, if I edit the mac file for a particular remote phone and duplicate the “line1” section into “line2” and “line3” sections, the phone registers on all three lines properly.

Is there a way to make EPM do this automatically? The $mac.cfg shows the line_loop section, but only seems to call it once, for the line that was assigned in the EPM Device List. Instead of specifying a single line, I’d like all lines on the phone to register identically.

Well, I came up with what I feel is a reasonable compromise.

I created two folders in my “tftpboot” folder. One is “local” and the other is “remote.” I then ran that endpoint manager and created a config for all phones as local phones (with the local IP address, as if they were inside the office). I copied all the generated .cfg files into the “local” folder.

I then did the same thing with the FQDN as the address, and copied all those configs into the remote folder.

I configured each phone to use ftp to download the configuration, and pointed to “local” for phones I’ll use in the office, and “remote” for phones I’ll use outside the office.

It seems to work and allows me some flexibility without a lot of pain. It would be nice if I could just move phones from inside to outside without having to change any settings, but that would be a lot to ask of my consumer-grade router (albeit running Tomato) and also may pose some security risks even if I did get it working.

Moving on now…