End Point Manager - Deployment Questions/Issues - Templates Won't Apply

I hope this message somehow finds its way to tm1000.

First of all, thank you so much for making this! It’s already made my deployment SO much better.

My deployment is based on the current versions of FreePBX and End Point Mananger as of 10/14/12. I have SNOM 710 and SNOM 760 phones. I found it very simple to remotely deploy the phones via the PHP HTTP server script. The problems I’m running into are essentially related to pushing settings to the phones. I’ve tried adding and editing various changes that I’ve made on one phone so that they will push out to all the other phones. I’ve verified the syntax, in fact it’s easy because the SNOM phone will provide an XML with anything that’s been changed so I can pull out the things I want to hard set. Any thoughts as to what I could be doing wrong?

Im not sure what you are doing or trying to do? What are you expecting the phones to do? have they been set to the server? are you rebooting them or are they rebooting? Have you checked the output to see if the settings have changed in EPM?

Sorry, I guess I should be more detailed.

So I have SNOM 760 and 710 phones. When I make a change and I want to add it into the configuration templates, I have tried copying the XML setting that I changed manually on the phone into the config on EPM, following the exact syntax as it is in the phone and even per the SNOM website, but with no success. Examples of what I have tried to add are:

display_name_number 3600 11.04 02:00:00 04.11 02:00:00 keyevent F_HOLD |^9([9]11)$|sip:9\[email protected]\d;phone=yes|d |^91([0-9]{10})$|sip:91\[email protected]\d;phone=yes|d |^9(801[2-9]{1}[0-9]{6})$|sip:9\[email protected]\d;phone=yes|d |^9(385[2-9]{1}[0-9]{6})$|sip:9\[email protected]\d;phone=yes|d |^([1-4]{1}[0-9]{2})$|sip:\[email protected]\d;user=phone|d Ringer6 These are just some of the examples. I've tried putting these in all of the config locations phone the phones in EPM but none of the phones take the settings. Am I doing something wrong?

When you are saving your customizations through the End Point Template(Configuration) Manager for desired {model}.cfg file, are you changing the “drop down” to the modified file versus the “original” {model}.cfg file?

In other words, when going to Connectivity/End Point Template Manager, then “editing” the custom template from End Point Configuration Manager (not to be confused with End Point Configuration Manager when selecting Connectivity and End Point Configuration to check for package updates…really wish they would put a different title between these two), then editing the {model].cfg file, and then saving your changes…are you changing the drop down to your newly created custom file BEFORE saving the template?

Because I found the default behavior leaves the “original” {model}.cfg in place when saving the template (which is overwritten with any provisioner/package updates).

that “Allow Saving Over Default Configuration Files” is not checked (ie enabled) in your Connectivity/End Point Advanced Settings.

I am sure. I just checked to be double sure. That’s not my issue.

Did you check the output of the file in tftpboot?

You need to debug in steps. Checking the phone is the last step.

I get that I need to debug in steps. I just wasn’t sure where to look, or rather it didn’t click in my head to look there but that’s obvious now.

I just checked and yes the settings are correct in the /TFTPboot. What can I check next?

Are you sure the phone is pulling the file from the server?

run

tcpdump port 69

and then reboot the snom

Well, I’m pretty sure it is because I was able to change the ringer and update the admin passwords, etc. On the Update tab on the SNOM, I have set the phones to point to the PHP web address for my system instead of the FTP/TFTP. Is that my problem?

Do I run that from the server or the phone (can you run commands from the phone?

It needs to be an IP. What exactly do you have the phones pointing to?

http://x.x.x.x/provisioning/p.php/ just like the EPM told me to point the phones to under HTTP mode. This setting is found on the phone under Advanced, Update tab, Setting URL.

I know the phones are at least getting some or most of the settings becuase when I change things in the tempate manager as far as the lines on the bottom of the pre-set tabs are concerned (ie Line 1, Line 2, Line 3, General, etc), those settings work without an issue.

HTTP is unsupported at this time.

You can check to see if the settings you are setting are in the HTTP version. I wish you would have told me that before we wasted our time checking TFTP.

Sorry, I thought they came from the same place, I also didn’t know that HTTP was unsupported. I honestly appriciate your help very much. I don’t mean to waste time. I’m very new to phone systems…but, I did indicate that I was using HTTP in my first post, “deploy the phones via the PHP HTTP server script”

Ok, so on that note, what is the best way to get the SNOM phones to connect to the TFTP server?

The reason I used the HTTP one is because that was the only way I was able to get the configs to even begin to work. I set an option in my DHCP server (Server 2008 R2) to point TFTP traffic to the PBX, but that never seemed to work. I appriciate any other thoughts or suggestions.

I’ve tried pointing the phone in rescue mode to the PBX (TFTP) server. That doesn’t work. Also, in TFTP mode, EPM says that TFTP isn’t configured correctly, but I’ve read that can happen so I’m not sure where to go from here. Any help is appriciated. Thanks.

Where have you read that “that can happen” EPM is pretty accurate about the TFTP server being configured correctly so I’d like to know where you found that.

To be honest I don’t remember where I read it…I just remember I was reading everything I could on how to configure EPM and I came accross that. That said, if that is indeed accurate, what can I do to get the TFTP server on FreePBX running so that I can use EPM that way instead of over the HTTP setting that is not supported?

See if this helps you out any: http://wiki.provisioner.net/index.php/Tftp