End Point Manager config pound key help

Hey guys! Freshly joined but seasoned in FreePBX and Asterisk. I’m having an issue with programming a DTMF key on a Grandstream phone. I’m trying to program a “Park” button to DTMF dial ##70# during a call. The problem isn’t the phone or the function, the problem is that the End Point Manager uses “#” for comments or remarks in the provisioning file “cfg$mac”. Is there any way to escape that so I can set my Grandstream function to =##70#? I have tried “##70#” with double quotes, ‘##70#’ with single quotes. I’ve tried the unicode slash code for the # sign, I’ve tried the URL code for the # sign. I’ve tried escaping it with a ##70# and so on. Is there any way to do this that anyone knows of?

Yes, I know I can change the ## blind transfer feature to something else but I still need the # on the end to help the call complete faster. My only other option is to log into the GUI of each phone and programming it that way. Not ideal but will work if I can’t find another solution.

I’m currently running freepbx 2.10 on top of PBX in a Flash. Asterisk version 1.8. End Point Manager version

Thanks for any help you can give me!

URL encoding actually worked. Setting %23%2370%23 turned into ##70# on the phone. I thought I had tried that already but apparently I failed at testing.

For future reference GRANDSTREAM uses the # as a comment. NOT endpoint manager

Technically, that’s incorrect.

Considering that Endpoint Manager uses a slightly modified version of the original Grandstream configs for these Grandstream phones, it would be safe to say that Endpoint Manager uses # as a comment, if only for these particular Grandstream phones. I see it as a necessary evil since Grandstream does this weird signature thing on their config files with their “special” tool, but the bottom line is Endpoint Manager is forced to use the Grandstream idea that # is for comments. Perhaps I should have specified they are Grandstream HD phones with weird signed config files.

Either way, I’m not sure your “you’re stupid” undertone in your response was warranted.

I didn’t remotely say you are stupid. What I did do was point out the fact that if you download the configuration files directly from Grandstream you will see they use # as a comment. Therefore they coded ‘#’ as the comment identifier. Telling people that endpoint manager uses ‘#’ for comments as if I created that is incorrect. It’s not endpoint managers problem that Grandstream uses ‘#’ as the comment identifier and then later forces you to use an encoded form of ‘#’. Do you get what I am saying here?

Yes I get what you’re saying. I went for the oversimplified explanation in my first post because ultimately whoever originally designed the # wouldn’t immediately matter to others that come across my post and want to help. Also those in the future looking for the same answer may also not understand or differentiate your provisioning tool vs Grandstreams and may not understand that, for these phones, Endpoint Manager recognizes the ‘#’ as comments.

Anyway, I apologize for jumping on you, I deal with a lot of programmers and most of them are uhh… cough meanies cough and will die defending their code/creation. Your post came off as a typical smart-ass programmer response which I understand now you didn’t mean.

Also, I’m curious as to why you didn’t go with XML provisioning vs the proprietary config generated by their tool? From what I see the XML doesn’t require being processed by their tool. I’m going to try and work on this a bit, we plan on rolling out a half dozen systems with these HD 2124 phones and XML makes more sense if this is the case. It may even handle a ‘#’ correctly. My guess was that maybe not all the HD line of phones supported XML configs.