Enable password for the gui

How to enable password for the gui. when I got to X.X.X.X it is automatically login me in

What is “Authorization Type” set to in Advanced Settings?

I don’t seem to find that setting?

Enable the two read-only settings at the top of the Advanced Settings page.

These one?

Log out. close the browser, and it will prompt you to log in again.
image

Or delete all of your session cookies. You will be prompted to log in again.

I don’t have that :wrench:/:gear: I have clear cookies and cache and no go…

Turn your phone sideways to see more.

iPhone 11 shows it.

I enabled the language setting and it still shows.
image

Nope is not there on the phone browser or the pc browser

In the “Advanced Settings” ( when enabled) you should have both AUTHTYPE and

Allow Login With DB Credentials YesNo

with a help popup that says

KEYWORD:AMP_ACCESS_DB_CREDS
When Set to True, admin access to the FreePBX GUI will be allowed using the FreePBX configured AMPDBUSER and AMPDBPASS credentials. This only applies when Authorization Type is 'database' mode.

You can also do it from a shell with

fwconsole setting -l|egrep "CREDS|AUTHTYPE"

and set it to 0 if it currently 1

fwconsole setting AMP_ACCESS_DB_CREDS --reset

If you have AUTHTYPE=none, well then you don’t have an AUTHTYPE at all

Thanks for the help I got it now. It was set to none

so what option should be selected so I get a logout button and requires user name and password to log in. I have played around and don’t seem to get it right

I would set up users in “User Management” with attention to the “FreePBX Administration GUI” section, then set the authtype to usermanager

1 Like

it dosent appear to keep the setting when I click save and apply and go back is not thre again

What "doesn’t appear. . . ", no mind readers here :wink:

Sorry the setting under Authorization type, not matter what I set it to it goes back to “None”

I would surmise that you possibly decided not to allow yourself to “Override Readonly Settings”

You are correct and thank you…It is fixed now

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.