en_GB Sound Language Pack Not Working


I’m running FreePBX 13.0.2.

I downloaded the en_GB Sound Language Packs and applied the changes.

Now when I dial the speaking clock or voicemail I just hear silence.

If I remove the en_GB Language Pack and apply, the default English sound pack works as per normal.

Any idea’s ?

Can you provide a call trace

How do I produce a call trace ?

In a shell type

asterisk -rvvvddd

Then make a call, copy and paste the output

The output produces over 68000 characters and it won’t allow me to paste in above 32000.

Is there a way to attached a file ?


I bumped your user level so it should allow you to post links.


That call answers and goes to hangup… I don’t see an attempt to playback

Ive done a longer call trace.

I’m dialing *60 for the speaking clock.


Seems to be working just fine. I’ve tested previously and gotten British to work.


You seem to be using G722, can you try turning it off and try again?

Someone recently had problem with G722 as well, I wonder if your problem could be related…

See: FPBX13 RC, G722 and 1-way audio - even to voicemail

Good luck and have a nice day!


Yes turning off G722 in the handset did the trick.

To summaries: -

I installed the FreePBX-64bit-10.13.66.iso distribution.
We have Yealink T23G handsets. By default G722 is enabled.

Using the default sound pack (English) with G722 enabled works fine.

If you swap the sound pack on FreePBX to English United Kingdom, you get silence if the handset is using G722.

If you disable G722 on the handset English United Kingdom sound pack works.

I will also post my findings in FPBX13 RC, G722 and 1-way audio - even to voicemail

A supplementary question about codecs.

Which codec is the best to use to avoid trans coding ?

Good to know…

Thank you for reporting back!

Good luck and have a nice day!


Follow-up Question.

By turning off G722 in the handset, extension to extension calls utilize en_GB sound packs.

However a call from a SIP trunk via a call group to an extension still hears the default US language.

Is there another setting somewhere ?

Side issue. Is there a contact email for the forum admin so I can request a tweak to my profile ?


Inbound routes, Other, Language…

You have to do this for each inbound route…

I am not sure but I think that adding

language = en_GB


Asterisk SIP settings, Chan SIP settings (if you are using it, Advanced General settings, Other SIP Settings

could also do the trick globally (as long as it is not overriden by the route, ie set to “default”)…

As for the forum admin I guess @jfinstrom could most likely help there…

Good luck and have a nice day!


Setting Inbound routes, Other, Language… to en_GB did the trick.

I will contact the forum admin @jfinstrom



You are welcome and thank you for reporting back!

As for @jfinstrom he should already have been pinged I think because we mentioned him in this thread…

Good luck and have a nice day!