Empty email sent by freepbx-cron-scheduler.php

FreePBX 2.9.0rc1.4
Ubuntu 4.3.2-1ubuntu11
Linux version 2.6.27-8-eeepc

Checking syslog and I can see emails being sent every hour by

Emails [email protected] [email protected]
where my-domain-name is valid.

The emails just contain ascii LF character (\nl)

Running from the command line also shows line feed and no error/output.

These messages started when I upgraded from Freepbx 2.7 (which had some issues - see http://www.freepbx.org/comment/reply/12792 ).

Any suggestions :slight_smile:

There is only one cron job.
To overcome this problem temporarily, I set the cron job to

/var/lib/asterisk/bin/freepbx-cron-scheduler.php >>/dev/null

Will this have any negative effect?


When updrading my system is found that there was two cron jobs for /var/lib/asterisk/bin/freepbx-cron-scheduler.php

Disable the one of them and the emails stopped.

Hello David,
as I mentioned, there is only one cron job in my list (shown via webmin).
All I have done via webmin is change the command to output to /dev/null so the command is still running every hour.
This has solved my problem of blank emails - but has it created any other problems?

The one cron job is required. Turning is off in the short term should be too bad. In the long not to good.

Every time i upgrade from 2.8 to 2.9 a second cron is created by the upgrade. I use webmin to cancel the second job . (centos 5.5)

This cron job runs every hour and starting a second one with in the hour seems to cause the email.

Should raise / check for a ticket for this.

Sorry that i can not offer any further suggestions

Went in and changed



if ($email) {



if ($email) {


This did not fix the problem - so I switched back to original $text=""; for safety.

Well generically speaking adding >/dev/null 2>&1 will not stop the cronjob doing it’s thing.
It’d be safer to just put >/dev/null for a start though.

That way you will still get an email generated if there is an error.

Seems to me that it’s only burying/hiding some bug or mis-configuration

also wondering about this.
I have a problem similar to the OP- I get emails from the freepbx-cron-scheduler job saying “got event fullybooted”. These seem purely informational so I would like to disable them by adding >dev/null 2>&1 but I don’t want to harm anything in the process. is this a safe modification to make?

The following file is the culprit.


Edit this file and at the very end after the ?> there is a blank line. Simply delete the blank line so that at the end of this file there is just a ?> with nothing after it and problem solved.

Anyone know if this is still an issue as of FreePBX 2.9 ? I’m still using v2.8 myself

At least I think that is the latest and yes it was an issue still.

But like in my previous post it is easy to fix.

I uninstalled hotelwakeup and still receive the blank cron /var/lib/asterisk/bin/freepbx-cron-scheduler.php emails. I receive one from root & one from asterisk. Any ideas on what’s causing this?

Anyone have an idea on this issue with 2.11 ?