Emergency Caller ID not applied

Weird issue today. FreePBX 14.0.13.4

User called 911. Call hit the correct route, which is marked as an emergency route.

[2021-10-15 13:41:10] VERBOSE[13759][C-0000be9f] pbx.c: Executing [[email protected]:4] Set("SIP/245-00019b58", "EMERGENCYROUTE=YES") in new stack

And it sent out the regular outbound cid because it didn’t apply the emergency cid.

[2021-10-15 13:41:10] VERBOSE[13759][C-0000be9f] pbx.c: Executing [[email protected]:12] Set("SIP/245-00019b58", "USEROUTCID=619664XXXX") in new stack
[2021-10-15 13:41:10] VERBOSE[13759][C-0000be9f] pbx.c: Executing [[email protected]:13] Set("SIP/245-00019b58", "EMERGENCYCID=") in new stack

But if you look at the extension, I have the emergency cid set:

MariaDB [asterisk]> select * from devices where id='245';
+-----+------+---------+------------+------+-------------+---------------+---------------+
| id  | tech | dial    | devicetype | user | description | emergency_cid | hint_override |
+-----+------+---------+------------+------+-------------+---------------+---------------+
| 245 | sip  | SIP/245 | fixed      | 245  | x245 User   | 619668XXXX    | NULL          |
+-----+------+---------+------------+------+-------------+---------------+---------------+
1 row in set (0.00 sec)

Have you done a reload? I believe it gets the caller ID from astdb

Yeah I thought of that too, thinking perhaps I was being dumb today and missed it.

[[email protected] ~]# asterisk -x "database show device 245"
/DEVICE/245/default_user                          : 245                      
/DEVICE/245/dial                                  : SIP/245                  
/DEVICE/245/emergency_cid                         : 619668XXXX               
/DEVICE/245/type                                  : fixed                    
/DEVICE/245/user                                  : 245                      
5 results found.

Dare I ask are you using device and user mode?

1 Like

Provide a call trace via pastebin.
https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII

Haha no not on this one :wink:

1 Like

That’s all I’ve ever wanted you to tell me, @lgaetz. Music to my ears :smile:

https://pastebin.freepbx.org/view/c9f75edf

1 Like

The trace only shows what you already know, line 86 is the mystery:

[2021-10-15 13:41:10] VERBOSE[13759][C-0000be9f] pbx.c: Executing [[email protected]:13] Set("SIP/245-00019b58", "EMERGENCYCID=") in new stack

It should be pulling from the AstDB for /DEVICE/245/emergency_cid, but its null. Share the dialplan via pastebin:

 asterisk -x "dialplan show macro-outbound-callerid" | pastebin

https://pastebin.freepbx.org/view/6df0cc5b

It would be needed that you supply a completed call, whether successful or failed, please extract the call from /var/log/asterisk/full so we see the timestamps

Yeah that’s in a paste bin link above

Apparently the EMERGENCYCID is null after seeing it is an emergency call

[2021-10-15 13:41:10] VERBOSE[13759][C-0000be9f] pbx.c: Executing [[email protected]:4] Set(“SIP/245-00019b58”, “EMERGENCYROUTE=YES”) in new stack
.
.
.
.
[2021-10-15 13:41:10] VERBOSE[1.3759][C-0000be9f] pbx.c: Executing [[email protected]:13] Set(“SIP/245-00019b58”, “EMERGENCYCID=”) in new stack

Did you set the 'route callerid" on that route ?

I think that was part of the original problem statement, not a solution!

That route’s CID needs to be set explicitly.

To override? That’s literally why there are individual emergency caller ids on each extension.

But does it ovrride the override ?, ‘dialplan show’ would be more nitpicky.

‘dialplan show [email protected]

As you wish.

https://pastebin.freepbx.org/view/df54e056

now explore outrt-7

dialplan show [email protected]

What direction are you trying to point me in? I know exactly what the route says it should do, but as far as I can tell I have a configuration setup correctly that didn’t work the way it’s supposed to.

https://pastebin.freepbx.org/view/9bcbab29

priorities 8 and 9 should be setting your callerid name and number if it goes through that route

If it doesn’t work for you then it is something else, (for me it works)