Email Voicemail messages

I know there is a Schmooze module to do this. Isn’t there a way to set up voicemail messages to email without a module to do it?


Yes. When you configure the extension you can specify that the VM is sent as email and enter an email address.

Thanks for the reply. I have that info entered for each user. How / where do I enter the email server for it to use to send the wav files? I think I have looked everywhere.

That uses the internal php functions to send mail. There is no need for a mail server. If your ISP blocks port 25 however you will have to use an email proxy instead.

Thanks tm1000,
I didn’t think they blocked port 25. Is there a log I can look at in the system to see if it tried to send? Is there a man page on setting up a suitable email proxy?


First you can see how many messages are ‘deferred’ by postifx (normal email server). If it’s anymore than 0 you know the system has an issue:

find /var/spool/postfix/deferred -type f | wc -l

You can see the status of your local mail server by doing:

tail -f /var/log/maillog

I used Webmin since I am not at the office. I did see that SendMail was running but there weren’t any messages in the queue.

I figured it out.

Found a thread where to enter my FQDN in for the system and off it went!


can you post the link to the thread you found that solved your issue? I also have a problem with voicemail sending to email and looks like the same thing where my domain name is not recognised by my mail provider SMTP Relay.


This is a bigger deal then simply ‘adding’ a FQDN using webmin. I am glad that worked for you, but is not the fix for most systems. In fact, to do this right, you’ll need to add an SMTP mailer program (ex msmtp) configure it with two or three config files, have a static IP address, or DNS name redirection (CNAM A record) … using a PORT other then 25 with your provider(s).

Anything sort of this (or different) (less consuming) is not the default process to get voicemail out to email to work (using a PORT other then 25 and/or anything SIMPLE to adjust).

voicemail out to email when using FreePBX 2.8/2.9 (and for sure 2.10) is not as straight-forward as posts claim.

Sorry, but I don’t remember exactly. I do remember going into Webmin and it was an easy fix. I think Sendmail needed a FQDN to be sending from. I went into my own system and did a quick look but didn’t find it. Sorry I am not more help :((

sawgood1 - What’s wrong with Postfix that is included by default?

Well, your question back to me shows you are expecting postfix to work by default or with a ‘simple’ port number change or FQDN update.

This is not the case. This is almost never the case. It does not work without much ‘playing around with’

Voicemail to email ‘out of the box’ with a simple configuration change will not work (esp. if you 100% sucess). This is a DRAG of FreePBX and always will be.

Well, if FreePBX makes it much longer going the way I see things going.

You need someone skilled with FreePBX, config file, and watching/understanding logs to make this work.

It has always been this way, and you know it too.
FreePBX does not deliver voicemail to email (turn key).

sawgood1 - What’s wrong with Postfix that is included by default?

That is not an accurate statement. It doesn’t send email without a relay server out of the box. Most email will be blocked if the reverse DNS is not correct. So if your ISP won’t setup reverse DNS your answer is correct.

However with a simple config line you can relay it to your existing email server. I advise my clients to add the FreePBX server as a trusted sender to their mail server.

If all else fails I have an email server that I can let them relay through.

If you purchase the sysadmin pro module you can configure via the FreePBX GUI the relay settings.