Email to Office365

System Admin (13.0.76) / Email

Log:
Feb 21 12:13:15 localhost postfix/pickup[4368]: C2657123290: uid=497 from=
Feb 21 12:13:15 localhost postfix/cleanup[4491]: C2657123290: message-id=[email protected]
Feb 21 12:13:15 localhost postfix/qmgr[4369]: C2657123290: from=[email protected], size=476, nrcpt=1 (queue active)
Feb 21 12:13:15 localhost postfix/smtp[4493]: connect to smtp.office365.com[2603:1036:902:106::2]:587: Network is unreachable
Feb 21 12:13:15 localhost postfix/smtp[4493]: connect to smtp.office365.com[2603:1036:102:90::2]:587: Network is unreachable
Feb 21 12:13:15 localhost postfix/smtp[4493]: connect to smtp.office365.com[2603:1036:404:a2::2]:587: Network is unreachable
Feb 21 12:13:15 localhost postfix/smtp[4493]: connect to smtp.office365.com[2603:1036:902:108::2]:587: Network is unreachable
Feb 21 12:13:15 localhost postfix/smtp[4493]: connect to smtp.office365.com[2603:1036:405:5f::2]:587: Network is unreachable
Feb 21 12:13:15 localhost postfix/smtp[4493]: C2657123290: to=[email protected], relay=none, delay=0.06, delays=0.02/0/0.04/0, dsn=4.4.1, status=deferred (connect to smtp.office365.com[2603:1036:405:5f::2]:587: Network is unreachable)

Are you using IPv6 in your network?

Hmmm, I think I turned it off at the router. I will check. Does FPBX depend on IPv6 to Office365?

Yes, I did turn it off.

Seems to me there were some questions about that a few weeks ago, and (working from memory) the consensus was to disable IPv6 for systems using Office365.

Hi!

It might be turned off at the router but is definitely active on your server so Postfix is trying to use it…

I suggest you turn it off on the PBX…

Good luck and have a nice day!

Nick

Sounds like a great setting for email configuration. HTF do I do it or find documentation?

Hi!

Either one of the results dicko pointed you to (if you don’t mind disabling IPV6 entirely, if you don’t even use in on your internal network) or add this to /etc/postfix/main.cf

inet_protocols = ipv4

Which disable it solely for Postfix…

re: http://www.postfix.org/IPV6_README.html#configuration

Choose the solution most suitable for your needs…

Have a nice day!

Nick

1 Like

Cute Dicko, thanks! But is that what I want to do? That is always the hard part, discovering the best strategy.

Thanks, That brings up an interesting point… How IPv6 is FreePBX in general? Since the default appears to be IPv6 on, is FreePBX IPv6 ready? Also, the Sys Admin/Office365 button, clearly is not a working option as is. Someone who understands the best overall solution may want to recommend a fix.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.