Email Setting do not work


I’m trying to configure email settings on my FreePBX box and i’m not having any luck. (ideally, i want emails sent with voicemails, etc… but right now none of that actually works.

I purchased the sysAdminPro and i tried to setup the email server settings. on trying to send myself a debug file, here is the last few lines of the message log:

Apr 12 11:00:19 localhost postfix/qmgr[4485]: 498EE9ED57: from=[email protected], size=407, nrcpt=1 (queue active)
Apr 12 11:00:19 localhost postfix/smtp[4508]: 498EE9ED57: to=[email protected],[]:25, delay=0.67, delays=0.13/0.03/0.44/0.08, dsn=4.0.0, status=SOFTBOUNCE (host[] said: 501 Your domain does not seem to be valid. Could not find MX record for your domain. (in reply to MAIL FROM command))

I never receive the email that it was supposed to send (not in junk/spam either). (I’ve redacted some of the sensitive data in the post, i.e. ip address/mail server/username & password).

the settings i have in email setup are as follows:
Use external SMTP Server
SMTP Servier:
use Auth
username: [email protected]
password: userpassword
my hostname: localhost
my Origin: localhost
my domain: localhost

I’m a complete newbie at FreePBX etc… therefore, forgive me if there is something else i should have posted. Please ask if you need more information (i may need a little instruction as to what file/log you may need).

Any help is appreciated.



shouldn’t it be ???
Also, have you checked your dns settings ??? can you ping google or from your freepbx server ???

it seems like it is your sending domain that is the problem …
use webmin and create and alias for your sending domain…

you are probably sending from [email protected] or something like that …

Thanks a ton for your reply.

i think it is trying to send from [email protected], but i dont know if that is ok or not.

i’ve not got webmin installed (and not certain what it is, but i’ll google and figure it out, hopefully).

Some people swear by webmin. I am not a fan. It certainly is not supported.

You can easily change your hostname and alias from the command prompt.

hostname xxxxx changes hostname
/etc/host has the alias

i couldn’t get admin to load–the port wouldn’t work–i think that is already being used for some sip settings or something (or a range from 10000-20000). not sure if that is over kill.
I am VERY green at all of this and never ever used linux before, it is very alien to me.

SIP uses UDP, webmin uses SSL over port 10000, a TCP service. No conflict.

This is not specific to Linux.

Just to stress it a bit, the old and long-gone Trixbox had a simple page for configuring emails.

I am not a FreePBX developer (willing to, but don’t have the time nor the skill) but I think it would be a pretty useful and simple module that interfaces with Postfix’s

The $25.00 Sysadmin Pro module has this feature. And it helps support the FreePBX project.