Email new voice mail notifications

The email function is not working. I have check my resolv.conf and it has the correct DNS servers, I checked my vm_general.inc to make sure it was commented out and not overriding any settings, but no emails are coming through. I tried from the user portal as well to manually send an email and nothing came.

Any ideas?

Okay…after digging through the mail logs it turns out I was blacklisted, so I looked it up CBL and the reason was “This IP address is HELO’ing as “localhost.localdomain” which violates the relevant standards (specifically: RFC5321”

So I suppose I have to try and change the originating send as and get remove from the blacklisting…grrr

I change the hostname and that solved the localhost.localdomain issue however how do I change the actual FROM address…it still says [email protected] no matter what I put in there and also the mail has incorrect information. It say:

Dial *98 to access your voicemail by phone.
Visit http://AMPWEBADDRESS/recordings/index.php to check your voicemail with a web browser.

The *98 is incorrect and the web site is incorrect. How can I edit the template?

Thanks

Okay I figured that out…the ONLY thing it still is doing is the name of person sending the email is Asterisk PBX. I don’t want that to be the sender. Is there a place to change that as well?

having the same issues, where did you change the hostname? /etc/sysconfig/network?

if not what was your procedure?

thanks,

I logged into the FreePBX GUI and went to the setting menu, Voice Mail Admin and then edited the email body field. Though I haven’t figured out to get rid of the “Asterisk PBX” as the sender yet.