Echo when on mute

Didn’t see anyone else in the forum with this issue. Anytime I put my phones on mute (calling extension to extension), the phone that didn’t hit the mute hears themselves. An echo.

I’m using both Aastra 6731i and a Polycom IP330, does it on both kinds.

Any idea to cancel out this echo? Other than that, all works great.

Please don’t double post. I have removed your duplicate post.

I suggest you read the post Dicko sent and supply more information so we can help.

Well he just sent me a link with no explanation as to why. I thought this was the wrong forum for my issue maybe and I couldn’t move it to another.

Well more info would be that my PBX is hosted. And I’m having echo issues. It’s purely SIP based, no FXO’s or the ability to use DADHI echo cancellation. And it’s between internal ext to ext. Its the worst when you mute the phone and the phone that is muted hears themselves.

I’ve used not only the phones listed above but also Cisco 525G2 and Grandstream GXP1400.
I’ve tried enabling jitter buffer, that didn’t work. I’ve tried manually setting up TX/RX gains in the config files. I’ve also manually turned on “silence suppression” or whatever echo canceling on the phones I could have. I’ve checked the jitter and latency between the site and the PBX and it looks fine.

Is there something I am missing? Or something I haven’t tried? I would think this would be a phone issue but I’ve read other forums that state its a PBX.

I’m a bit stuck because everything with echo cancellation relates to the cards, we can’t use those.

I think you missed some of the most important stuff.

What software versions are you using?
DAHDI (if related)
What Distro are you using?

First off, I apologize because when I deleted Dicko’s duplicate post I deleted your OS info.

The link was instructional so you send enough info.

What CODEC are you using?

What is the round trip time for the RTP?

( A buck against a penny it will be the hoster :slight_smile: )

He said he used another hosting company as a test.

I expect very high RTT times. Since the far end sidetone hybrid is not active when muted there is nothing to “absorb” the signal with a long transit time and hence the RTP stream coming back is delayed (not really an echo, echo and reverb are mechanical constructs).

I didn’t see that about another host. I saw he tried different phones though, maybe you deleted that bit too :slight_smile: poorly constructed cloud networks can delay rtp traffic, rtp debug and watch the timestamps, but yes, any echo/delay can cause user angst for users, especially if using any extension specific internal efforts at echo cancellation which can often exacerbate the problem, make it two bucks to the penny. . .

No worries, I appreciate the help.

Asterisk (Ver. 11.8.1)
PBX Firmware: 5.211.65-1
PBX Service Pack:

Also I stated it happens not only hard VoIP phones but soft phones as well. And yes I did try a completely different hosting vendor.

From my network to the hosted PBX…

round-trip min/avg/max/stddev = 38.716/40.051/42.196/0.904 ms

As for CODECS, I’ve used ulaw and g722.

I also stated it was with just MUTE, if the person is ON HOLD, nothing.

I’ve been running MTR’s all day off and on between three hosted PBX’s we have been testing with and only one had 1 to 6% packet loss on a certain node in the route to the PBX.
200 packets sent worst RTT was 90, average jitter was between 0 - 12.

I don’t think it is a network issue either. We have hosted PBX’s before and never experienced echo to this extent.

Was just told one of my techs turned up a PBX local on our network (same VLAN) and same issue with MUTE and echo.

You have any suggestions?

We are at a loss. We have installed FreePBX on actual hardware. We even put the hardware FreePBX on a Gig Switch alone with the phones and we are still experiencing bad echo with Mute. Nothing is helping.

Thanks for any help.

Sorry, not from me apart from looking to your network setup, perhaps for bogus IP duplicate hosts, it works for everyone else without echo :slight_smile:

Do I understand you correctly when you say the following:

“We even put the hardware FreePBX on a Gig Switch alone with the phones and we are still experiencing bad echo with Mute.”

Are you saying that you have installed FreePBX on physical dedicated hardware, connected the FreePBX server to a dedicated switch with only a few phones connected and you still have echo? A server, switch, a few phones and you still have echo?

This is by far one of the most bizarre thing I have ever seen.

He still hasn’t done the

you suggested though and gentoobob might itself be a clue . . .

I will take that as you do not know or fully understand nor do you care to help. I’ve seen your other post Dicko and your responses are to say the list “tasteless” when people have problems. I’ve never seen a forum that are ridiculed in a indirect way by two or three people. Very unprofessional sir.

Not everyone is looking for a direct answer but maybe some hints to look for or a direction to move to so they can understand the product or service better.

SkykingOH - thanks for trying to understand the issue.

Good day to you all.

Nowhere did I ridicule you, there is no mechanism to allow “leakage” within the rdp traffic stereams (audio paths), rx and tx are on different ports so any leakage (echo) can only be either a phone problem or a network problem especially if one leg of the bridge has specifically turned off TX (mute), I suggested you investigate your rtp streams where you can see (and even record/listen indirectly) the separate streams but rather unprofessionally you decided to ignored me.

All that and you still didn’t provide any information about your system.

I am not interested in the personalities. Just want to solve problems. I also do take the point someone in the right direction. Just handing an answer doesn’t solve much,

BTW I have no idea about the echo issue but I would like to find out it’s a first tome in 10 years