Early media sent to wrong IP

Hi guys, this is my first post and i’m a FreePBX/Asterisk beginner so i’m still finding my feet.

I have installed the FreePBX distro and everything seems OK. I can make inbound and outbound calls via our voip provider and get 2-way audio.

FreePBX has a public IP and NAT is not being used. My only problem is that when a user device is behind a NAT router (such as a home office), they don’t hear early media. I ran a trace with Wireshark and I can see that Asterisk is definitely sending the early media stream to the endpoint, but it is sending it the endpoint’s private IP instead of the public IP.

As soon as the call is answered, the media is sent to the endpoint’s NAT public IP and everything is OK. Does anyone here have any ideas please. It seems strange that everything works OK for the in-call media, but just not early media.

I know you will want to see configuration etc, but i’m not sure what is relevant to this issue. In the extension setup, NAT=yes. In the Asterisk SIP settings, NAT=no and IP=public

Any help is much appreciated, thanks.

Set your PBX in SIP Settings to NAT yes and define the public IP.

Thanks Tony, that worked :slight_smile: