FreePBX | Register | Issues | Wiki | Portal | Support

E911 Setup - FlowRoute

freepbx
Tags: #<Tag:0x00007fcd2e4f1638>

(Mike Dukes) #1

Hey Guys,

I have FreePBX alongside Flowroute for DID’s. We are up and running fine with extensions, DID’s, etc. I am to the point now where I want to get the 911 feature working, and it was “setup” before I got here, but I cant seem to get it working. I already have the E911 setup in FlowRoute, and it is set up under out main number DID with the correct associated address. I also have another setup for a new clinic we just opened. This clinic will be the first clinic with the new set up.

Does anyone have a step by step guide to correctly set up the 911 through FreePBX? I am banging my head here. I’ve looked through several forums. FlowRoute has a test 933 number to call for this, but I just get a “all circuits are busy” message. Any help would be greatly appreciated. If you would like some screenshots of my setup, just let me know

Thanks,
Mike Dukes


(Itzik) #2

Do you allow 911 and 933 in your outbound routes?

This usually indicates that the call had trouble reaching the provider. It could be for a number of reasons.
Post a call log of a failed call.

https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs


(John Jarrett) #3

I use FlowRoute and have E911 service through them and just now tested via 933 and all worked well.

Without any log files, I can suggest a few things to check.

1). Make certain your Outbound Route is set as an Emergency Route under Route Type.
2). Make certain that 911 AND 933 if you want test, are explicitly entered into your Outbound Route’s Dial Patterns.
3). Make certain that 911 AND 933 if you want to test, are explicitly entered into your Trunk(s) Dial Number Manipulation Rules.

John


(Tom Ray) #4

The Trunk Dial Number Manipulation Rules are not used for something like this. This is to manipulate the dial pattern after the match is made. So for example, you could have 5 Outbound Routes set up all that use your Flowroute trunk and in the Trunk’s manipulation rule you would add the tech prefix or + for the pattern that would be applied to all calls going out that trunk.

All you need for 911 to work is a proper Outbound Route that has the proper CallerID that matches the 911 registered number for the location.

Keep in mind this tells the Outbound Route to look and use the Extension’s Emergency CallerID setting. If that field is not populated, this won’t do anything.


(John Jarrett) #5

Blockquote The Trunk Dial Number Manipulation Rules are not used for something like this.

True… I do this out of habit. It is a bit redundant. Sorry!

Blockquote Keep in mind this tells the Outbound Route to look and use the Extension’s Emergency CallerID setting. If that field is not populated, this won’t do anything

Sort of goes without saying I would suppose… if you don’t have a CID set 911 can’t find you! Not certain 933 will return anything if your CID isn’t set either. I’ll have to play with that. And if Emergency Route isn’t True 911 still won’t find you. I use “911” as a whole, from call to CID database lookup, to PSAP to emergency response.

JJ


(Mike Dukes) #6

here are some images of the setup that I have. Your help is greatly appreciated.


(Mike Dukes) #7

Here is the flowroute set up. Flowroute says I am set up correctly

with them


(Mike Dukes) #8

I assume the CID would be the main DID? I’m new to the phone world, so thanks for the help.


(Mike Dukes) #9

I changed the CID to the main number and then realized that there wasnt any trunk sequences attached, so I chose the FlowRoute-Primary and FlowRoute-Secondary and when I dial 933, im getting a different message now. It says enter password? Seems odd, getting closer I suppose but still not there.


(Itzik) #10

Per this screenshot, there’s no Trunk connected to this Route.


(John Jarrett) #11

The CID is the telephone number Flowroute provided you. Not sradmin.

Remove the route password as everyone will have to enter a password in an emergency and that would not be good.


(system) #12

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.