E911 compliance related modules have been released


#1

Hello everyone,

The Stable versions of the following module updates have been released to be available for all.
paging 13.0.26.16, 14.0.16.2, 15.0.4.18
endpoint v13.0.133.1, v14.0.43.3, v15.0.27.3

Please make sure you update these modules to set up compliance with the new laws concerning calls to emergency services. For more information and setup documentation, see this post: FreePBX New E911 Compliance Features

It is recommended that everyone look over the documentation in that post. The features discussed may be useful even if your install is not required to comply with the new laws.


#2

Per Module Admin, I am running:

  • Paging and Intercom v14.0.16.2
  • EndPoint Manager v14.0.43.3

However, when I navigate to Connectivity-Outbound Routes, then edit my existing 911 route, I do NOT have a “Notifications” box on the “Additional Settings” page.

Any ideas?


#3

Hi @many_miles, that’s strange since you’re on the right version. Assuming you already did an ‘Apply Config’ or ‘fwconsole r’ after the update, can you try a different browser, or a private/incognito window to rule out any sort of caching issue?


#4

I just REperformed an fwconsole r, used two different browsers (Chrome and Firefox) in both regular and incognito modes (for a total of four tests), but still No Joy.

Attached are screenshots of my modules page and the Additional Settings page with the missing Notifications box.


#5

You really shouldn’t have to do this based on the versions I’m seeing, but can you try the following:
-update the pagingpro module to the latest available, and reload.
-assuming the option still doesn’t show up, reinstall paging with ‘fwconsole ma install paging’, and reload.

Also, can you tell me how you originally updated the paging module? For example, was it through the gui, or if through the command line, what command was used? I want to see if I can try to reproduce this. Thanks.


(christrati) #6

I thought this was only included with Page Pro, but maybe this is now included with the regular page module?

Chris


#7

I wasn’t sure how to update Paging Pro to the latest because it said it was already at the latest.

I reinstalled paging with fwconsole ma install paging and reloaded. No change.

I Disabled Paging Pro and reloaded. Now, it is showing up.

For the sake of completeness, I reenabled the Paging Pro module and the “Notifications” box again disappeared. (Redisabling that module returned the missing “Notifications” box.)

Perhaps my Paging Pro license expired, but I am not certain because I don’t know where to review licensing currency. How DOES one check for such?

As to the original manner in which I updated, I used a combination of both the command line and the GUI. First was the GUI to apply the first round of updates. I then applied the remaining updates via the command line. But, I think this is a red herring as I can duplicate the missing Notifications box by enabling the Paging Pro module.

Anyhow, thanks for the guidance.

T


(Jared Busch) #8

Sysadmin main screen shows the licensing status.

It will show no updates if your license is expired.


#9

Do you mean on this screen? I don’t see any updates, so I guess the license is expired?


(Lorne Gaetz) #10

From your screen shot:
image


#11

Ahh, ok. The poster said “Sysadmin main screen”.

I didn’t look further.

Thanks!


#12

Correct. The Notifications feature on Outbound Routes used to only be available with the paid Page Pro module, but it is now included for all users through the standard paging module.


#13

Thanks for the details. I’ll be looking into this.


closed #14

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.