DynDns Updater for linux DDClient

Hope one of you guys can help me here. I have installed and configured the script for DDClient which will run on my Fedora machine for FreePBX. When I run the client I get no issues but when I look at the Status I see … “ddclient dead but pid file exists”. Looking at the logs I see the following… "[[email protected] ~]# tail /var/log/messages
Oct 8 10:33:00 asterisk ddclient[8781]: FATAL: Error loading the Perl module IO::Socket::SSL needed for SSL connect.
Oct 8 10:33:00 asterisk ddclient[8781]: FATAL: On Debian, the package libio-socket-ssl-perl must be installed.
[[email protected] ~]#

I tried a Yum install Perl but it claims to exist and with the latest version, I am unsure about the Socket SSL that is needed, would this be a yum install SSL or something.

Sorry, still a bit of a newbie at linux :slight_smile:

Freepbx version = 2.9.0.7
Asterisk Version = 1.8.4.2

Hah, found it. SSL was enabled in the script and I guess SSL is not installed on Fedora, but if it can be used I would like it.

yum install perl-IO-Socket-SSL

Thank you sir!