Duplicate DIDs

I’ve been managing a hosted PBX with only one DID and a few extensions successfully. Now, I’m trying to add a second DID and a set of new extensions for a new sub-group in the PBX. I was able to successfully define the new DID as an incoming route, and when a new incoming call for that new DID enters the PBX, I can route it successfully to a new IVR and then to the new extensions, however I’m unable to define the new extensions to use the new DID for OUTGOING calls. Meaning-whenever one of these new extensions initiate an outgoing call, the number that appears on the screen is still the old, original DID.

I have created incoming and outgoing routes on FreePBX, but I wasn’t able to figure out how to tell specific extensions to use that specific outgoing route. I came across a module called Extension Routes, is that what I need in order to make this work? If so, how do I set it up? It seems to be installed but not running.

Thanks for your help!

You set the route destination in inbound routes, that is all you should have to do.

There is also a shortcut in the extension to simply add the DID and the route will auto create.

Here is a link to the documentation. In the future please state FreePBX, Asterisk and OS version.

Thank you:


Thanks SkykingOH,

For the record, I’m using Asterisk v. 11.8.1 and FreePBX running on SHMZ release 6.5 (FreePBX ISO).

Let me first describe my needs: I using the same PBX to serve three different organizations, each with its own DID for incoming and outgoing calls, its own IVR, extensions, etc… I’ve everything pretty much set-up, besides the outgoing calls thing. I’ve setup the incoming DID to be routed to a specific IVR and then to specific extensions and it’s working well. The problem is, that when I try to place an outgoing call from one of these extensions (of the 2nd or 3rd companies), it’ll always use the original DID for the outgoing call.

What am I doing wrong here?


Use the extensions routing module to create routes for each extension group.

I would check your outbound routes and trunks to see if you are overriding the outbound CID for all calls. Otherwise you can put the outbound CID on each extension and consider using the Extension Routing module from the FreePBX Distro that I have had great success with. It allows you to assign rights per extension for different outbound routes.

Thanks sqlguy, I also thought that the Extension Routing module would go a long way in solving my problem but when I try to access it I get the “The free Extension Routes module is installed, but not registered.” message. Any idea on how I can enable and take advantage of it?

Yes… You need to go to the “License” option of the Admin Module and register your deployment. You will need an account at the schmoozecom.com portal, but I believe that you can even do that after you enter your email address and assign a title (“Product Name”) to your deployment.

It is free to do and once you register your install you are able to purchase other modules from the portal. Once you license it you will need to log into the schmoozecom.com portal at https://portal.schmoozecom.com/index.php/login/index, then navigate to the “store” option. The “Extension Routing” is currently a free module, but you do need to add it to you cart, complete the free sale, then go back to your PBX and update the license so that it recognizes your right to use it. It sounds complicated but it is really fast and simple. :smile:

Thanks for the help, sqlguy!

I may be doing something wrong here… I registered to the schmoozecom.com store, added the Extension Routes module to my cart, but when I try to checkout it insists that I choose a deployment. My only option is Existing but whatever I enter in that free text box disappears after I go to the next field. Looks like a bug, or just a very complicated UI. Any advise?

I’ve also tried looking for a License option on my Admin > Module Admin page of my server but it’s just not there… What am I missing?