Duplicate CDR after upgrade

I am getting duplicate CDR after upgrading from 1.4.19 to 1.4.22 with freepbx 2.4. One records shows noanswer and the other shows that it was. Any idea’s??
I also have the same problem with 1.6 and freepbx 2.5, this is a new install that is my beta server.

2008-10-10 12:39:40 “House Line” pstn 3 ext-group SIP/pstn-09fd6f18 SIP/2683-09fd51e8 Dial SIP/2683&SIP/4003&SIP/4103&SIP/4005&SIP/4001|25|trdM(auto-blkvm) 31 22 ANSWERED 3

2008-10-10 12:40:11 “House Line” pstn 3 ext-group SIP/pstn-09fd6f18 SIP/2683-09fd51e8 Dial SIP/2683&SIP/4003&SIP/4103&SIP/4005&SIP/4001|25|trdM(auto-blkvm) 0 0 NO ANSWER 3

Any one???

Probably has to do with:

http://www.asterisk.org/node/48358

I’m sorry my poor english, but I couldn’t see any “fix” to this problem in the linked post ?
Also, it was posted over a year ago.
My problem came this week (oct-2008) in the fresh version.

I also see double cdr record for every SIP call.
One is answered and one is not.

/Johan

JohanL,

You can choose in your cdr configuration files whether or not to have cdr for unanswered calls. The default value is no, but on your box you said that you are seeing records for unanswered calls. Make sure you have the following line in your cdr.conf file:

unanswered = no

If you use specific conf files for specific cdr backends, make sure and check those conf files, too.

I do have “unanswered = no” in my cdr.conf [general] section.
My cdr status is as following:

pbx*CLI> cdr status
CDR logging: enabled
CDR mode: simple
CDR output unanswered calls: no
CDR registered backend: mysql
CDR registered backend: cdr-custom
CDR registered backend: csv
CDR registered backend: cdr_manager

But there is no "unanswered = no"
in my cdr_mysql.conf.

Am I supposed to enter it into the cdr_mysql.conf as well ?

/Johan

I noticed the same issue after upgrading my install from Asterisk 1.4.21.2 to 1.4.22.

So far the only fix (nothing more than a hack) I could come up with was to delete the duplicate entries via a SQL script scheduled to run every hour.

The SQL script: /root/clean_cdr_0_NO_ANSWER.sql

delete from cdr where disposition = 'NO ANSWER' and duration = 0 and billsec = 0 ;
exit

The cron shell script: /etc/cron.hourly/clean_cdr_0_NO_ANSWER

#!/bin/sh
mysql asteriskcdrdb < /root/clean_cdr_0_NO_ANSWER.sql

Did anyone come up with a better fix?

vs