DTMF tones too long AFTER being passed through FreePBX

FreePBX Version:
Customer PBX: Mitel (don’t know model)
ATAs: PAP2 and SPA-2102

Customer is using an old Mitel PBX at their office, but instead of using copper lines, they’re having us use a couple of Linksys PAP2 ATAs to provide a total of 4 inbound lines for the Mitel. The calls are being delivered properly and their IVR is heard fine. Pressing buttons for extensions is fine EXCEPT when there are 2 consecutive digits that are the same (eg. x1003 is seen by the Mitel as x103 because the 2 zeros run into each other). Putting a butt set on the line, I can hear the DTMF tones are REALLY long. Asterisk’s dtmf log shows proper duration (whatever length I press, normally around 250ms, but it will range into the 2000+ range if I hold the button down). Listening on the butt set, the tones are at least a full second. If adjacent digits are different, the Mitel detects them fine. If they’re the same, it only picks up the first.

I tried making adjustments to the Linksys ATA to shorten the dtmf tones that are passed through, but nothing I tried seems to work. Tones remain long and no break in between. I am not familiar enough with codecs and settings to know what to try next. Google has given me some leads, but nothing has worked thus far.

I’m not sure if there’s an adjustment in asterisk to deal with this, or if I should continue to focus on the ATA?

For those of you wondering why the hell we don’t just set them up with a full VOIP system, that’s coming in a couple of months when they get out of their current contract. For now, the owner wants to make the old system work as-is without adding cost of copper lines under a contract. I appreciate any help you can offer. Thanks.

The dtmfnode to the Mitel will have to be inband , force the extensions to be the same to the ata both ways.

Hi Dicko. Thanks for the suggestion. I tried it (see screenshot) and it didn’t make a difference. If I pause between button presses, it interprets both digits. But not when I press them like a normal caller would. Is it possible that the duration is effectively being doubled due to some kind of loopback? The IVR prompts sound normal. Any other suggestions? This customer is going to flip out if people can’t dial normal extensions tomorrow (even though he’s the one who didn’t want to go with copper for his inbound lines, which we suggested).

I would start by disabling the DTMF process info and AVT , These can generate spurious tones on the FSX port , also try disabling any echo canceling.

but you really should let asterisk do the heavy lifting and disable all your “supplementary services” and limit your codec to g711 also.



can help.