DTMF tones sometimes need to be typed very slowly to be decoded


I have a system that sometimes has a problem getting DTMF to be properly decoded when calling outside numbers.

I never have a problem dialing, it is always when someone tries to type something as simple as an extension once the communication has been established.

The problem only happens occasionally and changing the DTMF mode doesn’t appear to fix it…

It appears to be a timing problem as typing the numbers slowly seems to get them to register properly…

The phones are analog and they are connected to the PBX using a Sangoma A200 FXS module. As far as I can tell the card hardware DTMF decoding is activated (and so is the hardware echo canceller).

Does anyone have any idea what could be the cause of my problems?

Thank you very much and have a nice day!


Make sure your wanpipe and dahdi configs are mutually acceptable coverning dtmf processing.

Hi dicko!

in my wanpipe1.conf file I have

TDMV_HW_DTMF = YES # YES: receive dtmf events from hardware

so hardware DTMF decoding should work…

It looks like the file is no longer under FreePBX control since I get this in Sangoma Settings:

Global Configuration is disabled since there are /etc/wanpipe/wanpipe*.conf files

I had problems in the past and had to remove it from FreePBX control but I am pretty sure I had reverted that and returned it back to FreePBX control. It looks like one of the updates that was done to the startup scripts might have resulted in it no longer being under FreePBX control. I could be wrong though…

Maybe it is for the best because as far as I remember when Wanpipe is in DAHDI mode you could not activate hardware DTMF.

What setting should I play with on DAHDI’s side if any (considering the file appears to no longer be under FreePBX control)?

Thank you and have a nice day!


I would start by adjusting

toneduration =

1 Like

Thank you dicko, will try…

Have a nice day!


I had the same issue in the past with my digi card and it ended up being the echo canaceler that’s was bad. Ordered a new one and everything worked again

1 Like


I haven’t had any complaints in the last week (which doesn’t necessarily mean that the problem was solved).

If it turns up not being solved I will look into having this tested…

One of my modules (FXS) turned up to be defective (it was noisy) a while ago and had to be replaced under warranty so you are definitely right that a defective card/module is something to keep in mind…

Thank you very much and have a nice day!