DTMF tone bug on inbound calls

Just looking into the key configurations on our S500 phones.

Is it possible to reprogram the Voicemail button (envelope key) to use the REST-Voicemail instead ?

also, I have added a DND to the Function keys… when active the key is red, when inactive the key is green… is it possible to have the bulb off when inactive and red when active ? (no idea how to change this)

Separate note, and maybe i should start another thread (let me know and I will). The park function didnt do what i wanted so i added a “transfer to 70” button to put a call in the parking lot. However, when i do this, i get a transfer icon at the top of the screen that never goes away ( to the right of the clock) and i get two lines of text at the bottom of the screen “Parking enabled” and “1 Transferred Call” (this increments with every transfer and never goes away till i reboot the phone)… Is this a bug ?

Not currently possible. It may be worthy of a feature request.

How have you added the DND? Using the Rest App or a BLF to a featue code. A button using the DND Rest App uses Red/Dark, not Red/Green.

Explain what it did and what you expected it to do. In my testing, the the Park Rest App will park a live call or, if you are not on a call, it browse the parking lot.

When you press the History button, does it not clear these notices?

Thanks for the quick reply.

How do i do this ?

Ah ok, im using the BFL to the DND code, i just changed the button over to the REST-DND App, and its working as id like it to (although the codes are faster than the app, this will do)

When using the REST-Parking button in a call, the other end hears the DTMF tones and nothing happens. When using the Park button, the same happens (the caller hears the DTFM tones), when i transfer to parking lot 70, the call is parked as expected

No it doesn’t, although if i scroll down to the next page and exit, the transfer text disappears but the “Parking enabled” does’t disappear and the BFL on the REST-Parking app stays light up after the call is in the parking lot and the end call is terminated by the caller

Feature requests can be made at http://issues.freepbx.org, use forum credentials to login and select project TELE when creating a new issue.

I have just confirmed that all Sangoma phones park a live call properly with a button set to the Parking Rest App. Ensure that your phone firmware is up to date and that Rest Apps is also fully up to date then test again.

Thanks, i have submitted the feature request.

I just checked all modules are up to date, but still the same issue.

  • When i answer an incoming call and push the REST Parking app, i can hear the DTMF tones on the phone that made the call
  • When i call a phone and then push parking to park the call, it works…

Its only on inbound calls that i cant park…

Any ideas what would be causing this behaviour ? any way to troubleshoot it and work out whats causing it ?

I have spent the better parts of the last 4 days trying to work out why this isn’t working as expected (see above for specifics).

Im really lost at what to do, this doesn’t work as expected at all…

Do you have any other suggestions for us ?

Try using asterisk 11 (run asterisk-version-switch as root and select Option 2). After it installs make sure all your modules are up to date. Reboot the PBX. Give it another try. I think there are still issues with asterisk 13/Pjsip.

Thanks for the sugestion, we are not using PJ_Sip, we are using Chan_Sip, we moved to 13 as we were seeing other issues with 11

Please test this on Asterisk 11 as 13 even with chan_sip has lots of underlying changes

I just tested with Asterisk 11, exactly the same result

my understanding is the Parking soft key and REST-Parking app dial ##70# to park a call, however, transferring a call to the parking lot using the transfer button works differently in some way…

I just tested dialing other feature codes on an inbound call, none work, all i hear are tones on the callers phone but on an outbound call, all work as expected

I can also confirm that on other devices (softphone and a cisco 7975) attached to the same server, all feature codes work in both inbound and outbound directions and under both version 11 and 13

Am i missing something on the phone configuration that can cause this ?

I believe it would be ##70 not ##70#

Sorry, yea typo… issue is still the same regardless… its not the specific code, its all codes dial when the call is inbound