DTMF Problems w/Voicemail, etc. (Also, anyone with a PhonePower SIP TRUNKING account -- please read)

I am currently having major issues with DTMF tones in various and sundry configurations. ANY and all suggestions are welcomed at this point.

I have two inbound trunk providers and both have similar problems, but still different.

FreePBX 2.9.0.7 on Asterisk 1.8.6.0 on Centos 5.7 32-bit
Sip Provider #1 - SIPSTATION
Sip Provider #2 - PhonePower/Voip.com

My first problem is with remote Voicemail access from offsite.
I can call into the system, access our IVR, enter the extension #, and then press “*” for voicemail access. This works wonderfully. At this point, the system prompts for the password and I enter it – but it ALWAYS says invalid. I have checked the logs and it is always receiving a password of “” – i.e. nothing. In other words, DTMF works all the way up to the point of the voicemail password entry and then it quits receiving. I have tried both rfc2833 and inband audio – and it works with neither. Actually, with rfc2833 other things don’t work as well either, so I have set everything in the system I know of to inband (which seems to work reliably). I have also set the codec to ulaw/g.711 across the board and disable all other codecs.

The second problem happens only on PhonePower, with whom we have a SIP trunking account. When I call into our system from an outside line, we are having some rather odd issues with DTMF tones not being recognized at all from any phone calling in. The call hits our IVR and we hear everything, but cannot press any buttons to make a selection or dial an extension. If I create a custom route and send all calls from that DID directly to an extension, I have verified that the call sounds fine and audio is working in both directions. I have also verified that once the call is connected to this extension, I can press buttons on the remote phone and I actually HEAR the DTMF tones being properly echoed to the extension. Once again, I have dtmfmode set to inband on this trunk and on the extension itself.

Lastly, a somewhat unrelated problem (maybe), when I call into our PhonePower trunks, no audible ringing tone is ever generated back to the inbound caller. With our SIPSTATION trunks, inbound callers hear ringing properly if I set a delay before connect and set the “RINGING” field. With the PhonePower trunk, all the caller hears is dead silence until the call is answered. I have also experimented with the “progressinband” flag, but that doesn’t seem to help either in this case.

Basically, does anyone out there have any ideas?

And does anyone out there have a PhonePower/VOIP.com SIP Trunking account (NOT a personal use account) working well with FreePBX/Asterisk that I can compare notes with?

Also, a few other points of interest…

  1. I have setup a Google Voice trunk – and with everything else the same, it works fine for accessing voicemail remotely. It gets the DTMF password with no problem.

  2. I have turned on DTMF in the Messages log and also just checked the main log. With SipStation, DTMF tones are being registered by the system UNTIL they hit the voicemail password prompt, then the system just seems to totally quit listening for them.

Is this potentially a bug in how Asterisk is handling inband audio DTMF over a SIP Trunk inside the voicemail module itself???

Thanks in advance!

You might want to go check out there forums. I had an issue and one of their techs located the account and helped me identify the problem.

DSM Fan, are you talking about SipStation or PhonePower?

I’ve already spoken to PhonePower’s tech support staff – though I will probably be calling them again – and they have confirmed that everything looks good passing through their system on both ends (and it works fine on my end once it connects to an extension). It’s just that when it is in the in between state and connected directly to asterisk that things don’t seem to work. In some ways it almost seems like a mismatched codec issue – but EVERYTHING I can find is hardcoded to “allow ulaw” and I have checked to be sure I have “deny all” before everything first.

One thing that is a bit different with PhonePower is that there is no registration required – it is just strictly hardcoded to credentials based upon our static IP address. So I’m wondering if Asterisk may be getting confused by the fact that there is no SIP registration going on.

Have you tried calling yourself and just listening to the DTMF tones as you press them? This is often a useful technique for gaining relevant information.

You may also want to mess around with the dtmfmode= entry in your trunk settings. Choices are inband, rfc2833, info or auto.

Try with yet another provider. I’m able to access my voicemail from Callcentric and VOIP.ms.

Try using an FXO device and call in using a POTS line. My favorite FXO is the Obi 110, which you can pick up for $50.00 from Amazon.com.

@AdHominem

As I mentioned:

  1. I have tried dtmfmode on both the trunk and the extensions as all of allowable options.

  2. I have already dialed from an offsite line through the PowerPower trunk to an extension and I can both hear the tones audibly and see them being echoed in the message log and the Asterisk CLI.

  3. When dialing in on the SipStation trunk, DTMF’s work all the way through the system EXCEPT when you are trying to enter the password (at which point they do not show up in the message log or CLI either).

Also, changing providers at this time is not particularly feasible as I would have to get numbers ported and their offerings are not particularly attractive. Specifically, we need dedicated SIP business trunking with not less than 5 simultaneous call capability plus additional secondary trunks for at least two fax lines and a minimum of 3 DID’s.

Also, using an FXO device completely misses the point of this entire problem – I already have a 4 port TDM400P FXO DAHDi board which works just fine with existing inbound lines coming off a T1, this is what I am trying to ELIMINATE by going to a full VOIP solution.

I am curious if you ever resolved this. I am having the same issue. The only place that it appears is from my desktop phone trying to dial the password for voicemail. The touch tones are fine when I am using it for other calls (e.g. id for an external conference call).

In my case, I only experience the problem with my desktop phone (cisco 7960) and only with voicemail. I can use the desktop phone to dial numbers and use the key pad to key touch tones to external systems (e.g. conference calls).

On the other side, I can use an external phone and an internal softphone to access my voicemail without problem.

The only place that I currently experience the problem is my desktop phone responding to the password prompt for voicemail.

We did finally resolve the issue – it was actually being caused by the SIP Tracking/NAT Helper module of the Tomato firmware in our router. After I turned it off everything worked as expected.