DTMF not working from some Phones

I have a weird issue im trying to diagnose. Any help or suggestions appreciated.

Have a fully updated and commercially licensed FreePBX On-Premise deployment at a client… Runs great, no issues. Deployment has Sipstation Trunks and DID’s

We have 5 Snom D785 IP Deskphones, Snom M900 Basestation with a M80 setup. All run great no issues.

We have two Grandstream HT802 Dual FXS adapters setup. The issue we are having lies with a device connected to one of the HT802’s ports.

We have a Mircom TX3 F22 Touch Telephone Entry System that has a single pots line from the TX3 to one of the FXS ports on one of the HT802’s… This is installed at a condominium apartment building. The TX3 is installed in a locked vestibule area with all the residents names in it. On the back end of the TX3, each residents name is simply programmed with a phone number. The system is set with DTMF Door Open number 9 for all residents

When a guest walks up to the TX3, they press on the residents name and it calls them via the POTS line connected to the TX3, from the HT802, which is setup as an extension in FreePBX. Call goes out just fine, 2 way audio is just fine… This system/setup has been installed and working for a few years.

Every once in a while we get a call from the GM stating they received a complaint from a specific resident that their guest used the TX3, they received the call, but when pressing 9 on their phone the door did not unlock… This complaint is isolated but we do get it every once in a while. Every time, we put our cell phone, our office phone, and the GM’s phone into the system and have the GM go test it. Every single time, the call comes through, 2 way audio is working, and when pressing 9, the door unlocks…

So yesterday, we were onsite to complete some number ports from Nextiva to Sipstation and replace all the desk phones on this system. While we were onsite, the Board President of the Association happened to run into us and said he was having the issue with the door not unlocking when pressing 9. I said lets test it out while I monitor some things.

He pressed his name on the TX3, it rang on his cell phone (Verizon), he answered it, we had 2 way audio no issues there, he pressed 9 on his cell phone and the door did not unlock. We tried it twice. Right there with him, we put in my cell phone (T-Mobile), the GM’s cell phone (Comcast), my employees cell phone (Verizon) and we called each, all 3 received the calls, 2 way audio worked as normal, all 3 of us pressed 9 and the door unlocked every time.

So, every outgoing call is properly made by FreePBX and connects to the called number every time. We have 2 way audio as normal on every call. But a very small select few, nothing happens when they press 9 to unlock the door.

Does anyone have any suggestions on why this is happening or how to diagnose further???

What are the exact handset brand & model that the tenats use to press 9 to unlock the door?
Are the tenants that are failing to unlock the door by pressing 9 usual/same always or its random and do they use different phone types(brand & or model) from the others?. I feel like its some kind of DTMF setings on their sets.

I dont have a list of that kind of info. But, I believe the specific residents (happened to the the Board President) that I tested right in front of me yesterday was using an iphone with Verizon Wireless as the cell carrier…

I cant find any reason or anything on my end that would say its the TX3, or the HT802 or FreePBX or Sipstation. Because calls go through every time, no issue with the call, every time we input a number into the TX3 for testing purposes, whether its my cell phone, the GM’s cell phone, our office phone, the buildings main front desk phone, it works EVERY SINGLE TIME. so hard to diagnose…

DTMF can be sent ‘inband’ or as a sip message in a call , inband only works properly for ulaw/alaw but cell phones are gsm, the ata is responsible for extracting the DTMF signals , you could investigate any ata settings, turn on dtmf logging and/or replace the ata as good starting measures, also gather which carrier the failed calls atr using, I suspect Verizon is the underlying cause

Thanks @dicko Ill look at DTMF settings on the HT802…

I did replace the ATA a few months back from a CISCO SPA112 to this Grandstream HT802. Same results, every once in a while we get a single isolated complaint of a resident that cant open the door with pressing 9.

I see you edited your post…

So, up until yesterday, the failed DTMF carrier was ALWAYS Comcast Digital Voice landline… Yesterday was the first time it was brought to our attention that failed DTMF unlock was from a Verizon cell phone. And, it cant be carrier wide, because right after this residents failed and I tested it with this resident standing next to me 2 times, failed both times…I added my employee to the TX3 and tested called his cell phone which is ALSO a iphone and also Verizon wireless and it worked perfectly, door opened right up when pressing 9. So that had me even more stumped…

Here is the DTMF settings currently in the HT802 for FXS1 port that this Front vestibule TX3 Touch is connected to. We also have a smaller Mircom TX3 Nano at the back door of the high rise that all the same residents/DID’s are programmed into. That TX3 nano is connected same way to the same HT802 but on FXS Port 2. I asked this specific resident if the same thing happens on the back door TX3 Nano and Im waiting to hear back…

HT802 FXS1 - DTMF Settings

From the HT802 Manual - see below
DTMF Methods
The HT801/HT802 support the following DTMF mode:
• DTMF in-audio
• DTMF via RTP (RFC2833)
• DTMF via SIP INFO
Set priority of DTMF methods according to your preference. This setting should be based on your server
DTMF setting.
Can you test pressing 9 using a softphone installed in the users phone or set DTMF mode in FreePBX to Auto

What happens if the caller presses the button multiple times? Again DTMF logging will help.

Nothing happens if you press 9 multiple times. We tried that…

When you say set DTMF logging, do you mean in FreePBX? How do I turn that on?

Ill check DTMF settings on FreePBX…

No, I cant install softphones or anything on a residents phone.

SIP DTMF Signaling is set to RFC2833 in FreePBX, which matches Priority 1 DTMF: RFC2833 in the HT802

Turned DTMF logging on here.

How about setting it to auto in FreePBX

I can try that

I feel this is a carrier issue…

I turned DTMF logging on, had this specific resident that I tested with yesterday that was failing test again today while I watched the logs. Worked first time and I see DTMF 9 in the Asterisk log files after his number being dialed… so no clue…

I tried another one today and i had to hit 9 3 or 4 times and it finally worked. Did not work on the first try… so weird

Did the DTMF log show 9 appearing once, or multiple times?

Here the log sorted by DTMF. Appears to me, if Im reading this correctly, some of these residents are pressing * instead of 9 which would explain why the door isnt opening…

One question about the logs… what sets the time stamp in the logs? Because its way off… how do I correct that?

Found the time issue… Still set to UTC in Sysadmin>Timezone

Are the failed calls being answered on speakerphone mode on these mobile phones? I have seen phones when used on speakerphone not properly or reliably transmit DTMFs on occasion.