Dropping ip registrations

hi everyone
i am using FreePBX

i have a big issue that i need some help with
i am using didlogic.com as my service provider

i keep loosing ip registration with didlogic, actually i can constantly connect to one of their main servers (weird part is i can not receive calls through through main server) their other server that is closer to me in NYC i constantly keep loosing connection and therefore i am not able to receive calls or use that server for outgoing calls
if i connect to didlogic through xlite its working fine on both servers so it is not an issue with them since i already contacted them
i have another setup almost identical and everything is working fine

here is my config



xxxx:[email protected]/18xxxxxxxxx

i am using identical config on another system and i am able to be connected constantly on this one log file says its unreachable system says request sent but log says unreachable

see image


someone please help

I had a similar issue, which was the result of my firewall ports timing out. I set the udp timeout on my nat rules to 120, and tadaa, issue resolved.

Hope this helps.

where can i change this

That depends on the firewall. I use a SonicWall, and it is under >firewall >access rules >advanced >UDP Connection Inactivity Timeout (seconds). what firewall are you using?

also, on the firewall, make sure that you enable consistent NAT, and disable SIP transformations.

On your router or firewall, not on FreePBX.

The time the router leaves the UDP ports between your PBX and the server connected is too short.

You can try to get around this adding this setting in your trunk Outgoing Settings, in the “PEER Details” box:

qualifyfreq = 60

Let us know if that fixes it.

And, for all that’s holy, DISABLE any “SIP ALG” you have in the router. They’re a lot more trouble than else.

its d-link and udp time out is set to 300

300 seconds is 5 minutes.

Select “Settings” - “Asterisk SIP Settings” and have a look at these parameters in the “Registration Settings” section:
Registration Times (minexpiry) (maxexpiry) (defaultexpiry)

If minexpiry or defaultexpiry is more than 300 your registration doesn’t renew quickly enough.

However, the “qualifyfreq = 60” should poke the registrar every minute, so the UDP ports on your router should stay open indefinitely.

If you can check the state of your connections in the router, keep an eye on them and see when the router drops them.