Dropped calls from softphones


(Chris) #1

https://pastebin.com/VunEBqPM

i’m getting dropped calls after about 30 seconds between an android using GS Wave and OSX using Zulu.

ringing and voice works but only for about 30 seconds then the call is dropped

log in pastebin


(Sergio Lobera) #2

Are you using a STUN server on Asterisk SIP Settings ?


(Chris) #3

Asterisk PJSIP

here you can see i put the call on hold then it drops

[2020-06-05 13:06:52] VERBOSE[28555][C-00000006] res_musiconhold.c: Started music on hold, class ‘default’, on channel ‘PJSIP/401-0000000a’
[2020-06-05 13:07:23] VERBOSE[28555][C-00000006] res_musiconhold.c: Stopped music on hold on PJSIP/401-0000000a
[2020-06-05 13:07:23] VERBOSE[28555][C-00000006] bridge_channel.c: Channel PJSIP/401-0000000a left ‘simple_bridge’ basic-bridge <e4080602-eaed-4230-8785-99d7d427ee51>
[2020-06-05 13:07:23] VERBOSE[28555][C-00000006] app_macro.c: Spawn extension (macro-dial-one, s, 62) exited non-zero on ‘PJSIP/401-0000000a’ in macro ‘dial-one’
[2020-06-05 13:07:23] VERBOSE[28555][C-00000006] app_macro.c: Spawn extension (macro-exten-vm, s, 26) exited non-zero on ‘PJSIP/401-0000000a’ in macro ‘exten-vm’
[2020-06-05 13:07:23] VERBOSE[28555][C-00000006] pbx.c: Spawn extension (ext-local, 400, 3) exited non-zero on ‘PJSIP/401-0000000a’
[2020-06-05 13:07:23] VERBOSE[28555][C-00000006] pbx.c: Executing [h@ext-local:1] Macro(“PJSIP/401-0000000a”, “hangupcall,”) in new stack
[2020-06-05 13:07:23] VERBOSE[28555][C-00000006] pbx.c: Executing [s@macro-hangupcall:1] GotoIf(“PJSIP/401-0000000a”, “1?theend”) in new stack
[2020-06-05 13:07:23] VERBOSE[28555][C-00000006] pbx_builtins.c: Goto (macro-hangupcall,s,3)
[2020-06-05 13:07:23] VERBOSE[28619][C-00000006] bridge_channel.c: Channel PJSIP/90400-0000000b left ‘simple_bridge’ basic-bridge <e4080602-eaed-4230-8785-99d7d427ee51>
[2020-06-05 13:07:23] VERBOSE[28555][C-00000006] pbx.c: Executing [s@macro-hangupcall:3] ExecIf(“PJSIP/401-0000000a”, “0?Set(CDR(recordingfile)=)”) in new stack
[2020-06-05 13:07:23] VERBOSE[28555][C-00000006] pbx.c: Executing [s@macro-hangupcall:4] NoOp(“PJSIP/401-0000000a”, "PJSIP/90400-0000000b montior file= ") in new stack
[2020-06-05 13:07:23] VERBOSE[28555][C-00000006] pbx.c: Executing [s@macro-hangupcall:5] GotoIf(“PJSIP/401-0000000a”, “1?skipagi”) in new stack
[2020-06-05 13:07:23] VERBOSE[28555][C-00000006] pbx_builtins.c: Goto (macro-hangupcall,s,7)
[2020-06-05 13:07:23] VERBOSE[28555][C-00000006] pbx.c: Executing [s@macro-hangupcall:7] Hangup(“PJSIP/401-0000000a”, “”) in new stack
[2020-06-05 13:07:23] VERBOSE[28555][C-00000006] app_macro.c: Spawn extension (macro-hangupcall, s, 7) exited non-zero on ‘PJSIP/401-0000000a’ in macro ‘hangupcall’
[2020-06-05 13:07:23] VERBOSE[28555][C-00000006] pbx.c: Spawn extension (ext-local, h, 1) exited non-zero on ‘PJSIP/401-0000000a’


(Lorne Gaetz) #4

This is a signalling issue. If you look at the invite for the call, you will see an INVITE being sent, a 200 OK coming back and the final required ACK is going astray. Possible NAT misconfig, possible router ALG.


(Chris) #5

sorry i’m not sure how i’d go about troubleshooting that
is there any other logs that would help suggest it was ACK or NAT?


(Sergio Lobera) #6

See on your router if you have any SIP helper or SIP ALG and disable that.


(Chris) #7

We have Dell Switches, PfSense Firewall and the router from our business isp
i’ve asked them if SIP helper or SIP ALG is set by them on the router


(Chris) #8

they’ve confirmed “SIP is disabled by default on our CPE.”


(Chris) #9

Its interesting that it only drops the calls when the call is made from a softphone which is using Asterisk SIP chan_pjsip

when the call is started from zulu its ok


(Sergio Lobera) #10

Zulu doesn’t use SIP as signalling, that’s the reason.


(Chris) #11

I’ve just been doing some testing with pfsence support and heres what they’ve found

"It appears that your FreePBX box is rejecting an ICMP port of some kind (possibly keep-alive packets from the SIP client to the SIP server). As such, the SIP transaction is being terminated. This doesn’t appear to be an pfSense issue, but likely a misconfiguration on your freePBX box. I would recommend double checking your configuration on the PBX to ensure you have the proper ports open and configured. See the attached screenshot for reference.

"


(Chris) #12

i just want to add becuase i have pfsense the firewall is disabled on FreePBX


(system) closed #13

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.