Dropped calls - Dropped audio - stuttering ivr - on new FreePBX distro -restore settings from backup

I have a new install of FrePBX distro, Asterisk (Ver. a Dell dual core opteron 2220 server w/2tb raid mirror. It is behaving badly!

Symptoms are: calls drop after attendant picks up queue. Call audio dropping out on one side of a call. dtmf droppouts, IVR audio dropping out and stuttering/repeating (including voice prompts, like during transfers, ) These symptoms are random and not related to call volume.

As for volume:
I have 6 queues about 25 active calls/queues, about 55 total extensions.

Configuration: Other than a stock install, i did yum update and updated the FreePBX core and modules, then restored from a backup of an old server that was going bad, that server had no audio problems though.

Old “server” Dell P4 computer, was originally a elastix, but I had problems with that server and cisco phones so I upgraded asterisk to 1.6 and freepbx to the latest. That server was running ok with asterisk 1.6, but reporting hd errors and the cdb never worked after I upgraded asterisk.

My thought are that the entire problem is related to the internal timing. I have tried adding internal_timing = yes in asterisk.conf but no change.

I could move forward with compiling in different timing sources but last time I recompiled asterisk, I broke as much as I fixed.

I might try building a new server with FreePBX distro or Asterisk Now on a spare dell 2x P4 XEON I have sitting around (but this is scsi and so no 1tb drives… no call recording option)

I could build a new server with some other freepbx that uses asterisk 1.6

I was thinking about paying for support, but the options for support seem vague and possibly costly given the $225/hr rate… Hint support sales - we like per ticket pricing.

Can I check/change the timing source without re-compiling everything?

Any other advice?

Update: Same issue, I installed asterisk now with asterisk, updated freepbx to the same version and restored a backup.

This seems only to occur when a call reaches the “operator” then the call is traansfered to another desk. I have tried transferring with the phone, with iSymphony, same result. I have changed the operators cisco 7960 frimware from 8.8 to 8.12.

These calls go from -inbound route, time condition, call flow control (holiday greeting), to a queue, then to operator. 1/15 calls, operator has audio problems, Operator transfers to extension, 8/10 calls have audio problems.

I have several hundred calls a day on the same system that go to other queues, with no problem. No problem when a call is transferred to voicemail.

From the settings I can see that the internal timing is still enabled with this distro.

PBX Core settings

Maximum calls: Not set
Maximum open file handles: Not set
Verbosity: 0
Debug level: 0
Maximum load average: 0.000000
Minimum free memory: 0 MB
Startup time: 17:54:00
Last reload time: 17:54:00
System: Linux/2.6.18-194.el5 built by root on x86_64 2010 -08-24 20:45:59 UTC
System name:
Entity ID: 00:04:23:cb:b8:d8
Default language: en
Language prefix: Enabled
User name and group: /
Executable includes: Enabled
Transcode via SLIN: Enabled
Internal timing: Enabled
Transmit silence during rec: Enabled
Generic PLC: Enabled

  • Subsystems

    Manager (AMI): Enabled
    Web Manager (AMI/HTTP): Disabled
    Send Manager FullyBooted: Disabled
    Call data records: Enabled
    Realtime Architecture (ARA): Disabled

  • Directories

    Configuration file:
    Configuration directory: /etc/asterisk
    Module directory: /usr/lib/asterisk/modules
    Spool directory: /var/spool/asterisk
    Log directory: /var/log/asterisk

I am running out of ideas with the exception of the internal timing. Thanks in advance for anyone that might be able to help.

I have decided to buy a Sangoma UT50 after reading up on similar issues on pbxinaflash forum.

The UT50 did not fix the problem. It does increase the overall call quality for every call. I have literately tried every thing I can think of. Adjusting QOS settings, Changing the inbound route to go directly to the phone (cisco 7960 with 8-12-00) update the firmware, change the canreinvite, nat. The most strange thing, I have 4 other did’s that come into the same server the same way but go to another queue. All those agents are fine. Outbound calls are fine.

Very strange. The operator can put a call in the parking lot, then the user can pick up the parked call with no audio problems.