DPMA Broken Conflict with Endpoint Manager

Checked my freepbx 14 this morning and saw there was an automatic security patch applied to DPMA. Hit apply in the FreePBX gui and now none of my Digium phones will connnect.

Tried to downgrade DPMA and it tells me there’s a conflict with Endpoint Manager. My phone system is essentially dead now.

Anyone else seeing this??

eventually had to disable phone apps in order to disable endpoint manager and re-install DPMA. Obviously not a good solution.

DPMA and phones began functioning again.

Enabled EPM again and phones get kicked off again.

Looked at my endpoint manager settings and I had profiles for diguim models (oddly not the model D80 on my desk). Removed those, disabled EPM again and phones came back on with the DPMA config.

Enabled EPM again, thinking without the digium templates maybe it won’t conflict and phones again went dead.

When End Point Manager is enabled I get a security warning in the dashboard:

Module: “Digium Phones Config”, File: “/var/www/html/admin/modules/digium_phones/etc/res_digium_phone.conf altered”

Firstly there is no module named DPMA. Secondly you can’t run digium phones module and EPM at the same time. EPM now does dpma configs.

Well you need a DPMA license to run the Digium Phones Module and in the Gui under Admin > Digium Add-ons it’s called “Digium Phone Module for Asterisk” AKA DPMA so perhaps DPMA isn’t the Module itself but it seems to be part of it.

As far as not being able to run both of them at the same time, this was something that just occurred this morning with a security update for the Digium Phone Module. Prior to this morning everything was fine.

I saw the announcement a little while ago that Endpoint Manager would now support Digium phones without a license like it had for sangoma phones however I must have missed the part where it explained that this would cause the Digium phone module to stop working properly.

We didn’t explain that but yes you can’t use both at the same time.

OK, now I know.

Kinda seems like an important piece of information that should have been mentioned though no?

Ok, this is actually becoming an issue.

I have several sites that have a mix of Sangoma and Digium phones. I have Digium D80’s at these sites and the Sangoma DECT phones as well. I configured the sangoma phones through EPM and the Digiums through the Digium Phone Module. These worked happily together in the past.

I just went to re-configure my own phone system using only EPM (both digium and sangoma phones) and find that the Digium D80 isn’t even listed as an available model in Endpoint Manager. If I disable endpoint manager my DECT phones will not connect the next time the base reboots. If I remove Digium Phone Module my Digium phones won’t connect.

There’s got to be a better solution here.

We are working on getting it so EPM can still be installed with the Digium Phone Module but not manage the Digium phones. If you choose to have EPM manage Digium phones than you have to not use Digium Phone Module. We are also really close to getting D80 supported in EPM hence all this work and why EPM has to support DPMA.

@tm1000 can comment on when a update to EPM will be released to allow both EPM and Digium Phone Module to conicide again.


Thanks, Tony. Unfortunately I’m in kind of a pickle at the moment here having D80’s on site with sangoma phones. A fix really can’t come soon enough.

Uninstall EPM. Your Dect phone will keep the config it has and keep working for the time being.

This will be resolved in endpoint v14.0.2.182 which is being released in the next hour. DPMA override in EPM is disabled in global settings of EPM. In this default mode it won’t overwrite the files until you enable it in EPM.

1 Like

Thanks guys, appreciate the fast work. I’ll wait for the update.

Blockquote This will be resolved in endpoint v14.0.2.182 which is being released in the next hour.

Was this ever released? it’s not showing up on my system when I check for module updates…

I installed it today.

fwconsole ma downloadinstall endpoint --tag

Or you can try

fwconsole ma --edge upgrade endpoint

Thanks PitzKey, that worked.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.